Bug 1252961 - qBittorrent fails to build on ppc64le
qBittorrent fails to build on ppc64le
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
rawhide
ppc64le Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabio Alessandro Locati
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F-ExcludeArch-ppc64le/PPC64LETracker
  Show dependency treegraph
 
Reported: 2015-08-12 11:26 EDT by Rafael Fonseca
Modified: 2015-12-31 18:28 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.2.3-2.fc22 qbittorrent-3.2.4-2.fc23 qbittorrent-3.2.4-2.el7 qbittorrent-3.2.4-2.fc22 qbittorrent-3.2.4-2.fc21 qbittorrent-3.3.1-2.fc23 qbittorrent-3.3.1-2.fc22 qbittorrent-3.3.1-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-19 13:27:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add support for ppc64le (1.34 KB, patch)
2015-11-05 05:39 EST, Rafael Fonseca
no flags Details | Diff

  None (edit)
Description Rafael Fonseca 2015-08-12 11:26:35 EDT
Description of problem: qbittorrent fails to build on ppc64le with the following error:

checking for boostlib >= 1.35... yes
configure: Boost CPPFLGAS: -I/usr/include
checking whether the Boost::System library is available... yes
configure: error: Could not find a version of the library!
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.XHeM2R (%build)
    Bad exit status from /var/tmp/rpm-tmp.XHeM2R (%build)
Child return code was: 1


Version-Release number of selected component (if applicable): 3.2.1.-1


How reproducible: koji-build qBittorrent on ppc64le.

Additional info: The problem is that the m4 file checks for specific 64-bit architectures to use the correct library dir and the check does not include the ppc64le architecture. Because of that, the boost libraries are not found. There is patch upstream [1] waiting to be merged.

[1] https://github.com/michelmno/qBittorrent/commit/2a9e95ec7f19e6a51394b5f6c83eab05a61cbd4c
Comment 1 Fedora Update System 2015-08-17 05:45:59 EDT
rb_libtorrent-1.0.6-1.fc23,qbittorrent-3.2.3-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/rb_libtorrent-1.0.6-1.fc23,qbittorrent-3.2.3-2.fc23
Comment 2 Fedora Update System 2015-08-17 05:47:07 EDT
rb_libtorrent-1.0.6-1.fc22,qbittorrent-3.2.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rb_libtorrent-1.0.6-1.fc22,qbittorrent-3.2.3-2.fc22
Comment 3 Fedora Update System 2015-08-17 05:49:08 EDT
rb_libtorrent-1.0.6-1.fc21,qbittorrent-3.2.3-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rb_libtorrent-1.0.6-1.fc21,qbittorrent-3.2.3-2.fc21
Comment 4 Fedora Update System 2015-08-19 04:07:50 EDT
Package rb_libtorrent-1.0.6-1.fc22, qbittorrent-3.2.3-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rb_libtorrent-1.0.6-1.fc22 qbittorrent-3.2.3-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13688/rb_libtorrent-1.0.6-1.fc22,qbittorrent-3.2.3-2.fc22
then log in and leave karma (feedback).
Comment 5 Rafael Fonseca 2015-08-21 05:14:59 EDT
Unfortunately, version 3.2.3 doesn't contain the commit that fixes the issue.
Comment 6 Fedora Update System 2015-08-31 23:36:45 EDT
qbittorrent-3.2.3-2.fc23, rb_libtorrent-1.0.6-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-09-01 03:26:04 EDT
qbittorrent-3.2.3-2.fc21, rb_libtorrent-1.0.6-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Rafael Fonseca 2015-09-01 04:33:03 EDT
As per comment #5, the issue hasn't been addressed, so I'm reopening the bug.
Comment 9 Fedora Update System 2015-09-01 08:19:48 EDT
qbittorrent-3.2.3-2.fc22, rb_libtorrent-1.0.6-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fabio Alessandro Locati 2015-10-29 13:40:57 EDT
It seems like it's an autoconfig problem and not a qbittorrent problem, is this correct?
Comment 11 Rafael Fonseca 2015-10-30 06:45:53 EDT
(In reply to Fabio Alessandro Locati from comment #10)
> It seems like it's an autoconfig problem and not a qbittorrent problem, is
> this correct?

If it is, it was addressed by the upstream project anyway. There is a patch [1] which was committed after the latest released version.

[1] https://github.com/michelmno/qBittorrent/commit/2a9e95ec7f19e6a51394b5f6c83eab05a61cbd4c
Comment 12 Fabio Alessandro Locati 2015-10-31 06:51:46 EDT
afaics, that commit has never been merged in the official repository. Am I wrong?

A different commit has been pushed to the official repository [1] on Aug 30, which seems to address the same problem.

I have pushed [2] a new version to the testing repository that has been released after Aug 30. If that patch fixed the problem, this release should work properly.


[1] https://github.com/qbittorrent/qBittorrent/commit/45ef98b077297821f98c741637845ae051c6cdfd
[2] https://bodhi.fedoraproject.org/updates/FEDORA-2015-0112c5acda
Comment 13 Rafael Fonseca 2015-11-02 04:27:34 EST
(In reply to Fabio Alessandro Locati from comment #12)
> afaics, that commit has never been merged in the official repository. Am I
> wrong?
> 
> A different commit has been pushed to the official repository [1] on Aug 30,
> which seems to address the same problem.

Ops, that's the correct commit, you're right.

> I have pushed [2] a new version to the testing repository that has been
> released after Aug 30. If that patch fixed the problem, this release should
> work properly.

Perfect, thank you!
Comment 14 Fedora Update System 2015-11-03 03:33:24 EST
qbittorrent-3.2.4-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-812ff661d7
Comment 15 Fedora Update System 2015-11-03 03:33:58 EST
qbittorrent-3.2.4-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0112c5acda
Comment 16 Fedora Update System 2015-11-03 03:34:19 EST
qbittorrent-3.2.4-2.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ba5eced9aa
Comment 17 Fedora Update System 2015-11-03 03:34:40 EST
qbittorrent-3.2.4-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2a9b370747
Comment 18 Fedora Update System 2015-11-04 15:53:39 EST
qbittorrent-3.2.4-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Rafael Fonseca 2015-11-05 05:39:09 EST
Ok, I know what the problem is now. After changing the m4 file, you can't just run the existing configure. You need to run the bootstrap.sh to update the configure script first, so that the test for ppc64le is included.

I did that locally, so I think just applying the attached patch is enough to get it working (that way you don't need to include any new build requires).
Comment 20 Rafael Fonseca 2015-11-05 05:39 EST
Created attachment 1090014 [details]
Add support for ppc64le
Comment 21 Fedora Update System 2015-11-14 15:23:01 EST
qbittorrent-3.2.4-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2015-11-14 21:20:47 EST
qbittorrent-3.2.4-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2015-11-14 21:49:15 EST
qbittorrent-3.2.4-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 24 Rafael Fonseca 2015-11-16 05:14:17 EST
As per comment #19, the fix is there but the package must be recompiled with a  patch (comment #20) for the issue to be resolved.
Comment 25 Fedora Update System 2015-12-07 06:30:21 EST
qbittorrent-3.2.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-2b8947bac6
Comment 26 Fedora Update System 2015-12-07 06:30:22 EST
qbittorrent-3.2.4-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-37636003bd
Comment 27 Fedora Update System 2015-12-07 06:30:30 EST
qbittorrent-3.2.4-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-60051665d4
Comment 28 Fedora Update System 2015-12-07 18:21:49 EST
qbittorrent-3.2.4-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update qbittorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-37636003bd
Comment 29 Fedora Update System 2015-12-07 23:31:42 EST
qbittorrent-3.2.4-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update qbittorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-2b8947bac6
Comment 30 Fedora Update System 2015-12-08 02:21:20 EST
qbittorrent-3.2.4-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update qbittorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-60051665d4
Comment 31 Fedora Update System 2015-12-10 09:08:27 EST
qbittorrent-3.3.1-2.fc22 rb_libtorrent-1.0.7-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd2f2dff6c
Comment 32 Fedora Update System 2015-12-10 09:08:28 EST
qbittorrent-3.3.1-2.fc23 rb_libtorrent-1.0.7-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-92fcafd752
Comment 33 Fedora Update System 2015-12-10 10:21:49 EST
qbittorrent-3.3.1-2.el7 rb_libtorrent-1.0.7-2.el7 qtsingleapplication-2.6.1-25.el7 qtlockedfile-2.4-19.20150629git5a07df5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-bda03b0dd9
Comment 34 Fedora Update System 2015-12-11 01:01:24 EST
qbittorrent-3.3.1-2.fc23, rb_libtorrent-1.0.7-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update qbittorrent rb_libtorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-92fcafd752
Comment 35 Fedora Update System 2015-12-11 14:57:46 EST
qbittorrent-3.3.1-2.fc22, rb_libtorrent-1.0.7-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update qbittorrent rb_libtorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd2f2dff6c
Comment 36 Fedora Update System 2015-12-12 15:23:26 EST
qbittorrent-3.3.1-2.el7, qtlockedfile-2.4-19.20150629git5a07df5.el7, qtsingleapplication-2.6.1-25.el7, rb_libtorrent-1.0.7-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update qbittorrent qtsingleapplication qtlockedfile rb_libtorrent'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-bda03b0dd9
Comment 37 Fedora Update System 2015-12-19 13:26:51 EST
qbittorrent-3.3.1-2.fc23, rb_libtorrent-1.0.7-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 38 Fedora Update System 2015-12-20 02:52:31 EST
qbittorrent-3.3.1-2.fc22, rb_libtorrent-1.0.7-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 39 Fedora Update System 2015-12-31 18:28:44 EST
qbittorrent-3.3.1-2.el7, qtlockedfile-2.4-19.20150629git5a07df5.el7, qtsingleapplication-2.6.1-25.el7, rb_libtorrent-1.0.7-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.