Bug 125298 - need way to carry over old lease to dhclient
need way to carry over old lease to dhclient
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: ReadOnlyFS
  Show dependency treegraph
 
Reported: 2004-06-04 11:40 EDT by Alexander Larsson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 08:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to implement -ns (1.78 KB, patch)
2004-06-04 11:40 EDT, Alexander Larsson
no flags Details | Diff
Don't set ip to 0.0.0.0 if we have a lease for the current ip already (1.96 KB, patch)
2004-06-07 16:03 EDT, Alexander Larsson
no flags Details | Diff

  None (edit)
Description Alexander Larsson 2004-06-04 11:40:23 EDT
In the readonly nfs root case we don't want to down the interface
before requesting an ip, as that kills the root filesystem. We need a
flag that disables this behaviour.
Comment 1 Alexander Larsson 2004-06-04 11:40:59 EDT
Created attachment 100869 [details]
patch to implement -ns
Comment 2 Alexander Larsson 2004-06-04 11:41:32 EDT
This patch works for me if i put DHCLIENTARGS=-ns in
/etc/sysconfig/network.
Comment 3 Alexander Larsson 2004-06-04 12:20:31 EDT
Hmmm, in fact the interface isn't downed, the hang is just when doing
"ifconfig eth0 0 up". This should be a nop since the interface is
already up. I dunno whats causing this, will investigate. Hold on the
patch until this has been further analyzed.
Comment 4 Alexander Larsson 2004-06-04 12:57:00 EDT
Ah, so the "0" is whats causing it. It sets the interface ip to
0.0.0.0, which is needed when you broadcast for the initial dhcp ip.
What we need to do is to make it do a renew instead, and carry over
the lease from the old dhcp call.
Comment 5 Alexander Larsson 2004-06-07 16:03:08 EDT
Created attachment 100941 [details]
Don't set ip to 0.0.0.0 if we have a lease for the current ip already
Comment 6 Alexander Larsson 2004-06-07 16:03:57 EDT
With this patch things work if i carry over the dhcp client leases
file from the initrd.
Comment 7 Daniel Walsh 2004-06-09 14:17:20 EDT
Patch applied to dhcp-3_0_1rc12-8

Dan
Comment 8 Mark McLoughlin 2004-08-24 08:33:50 EDT
Closing, this is working fine
Comment 9 John Flanagan 2004-12-21 14:41:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html

Note You need to log in before you can comment on or make changes to this bug.