Bug 1252997 - 'Mouse and touchpad settings' in System Settings provides no way to control right-click settings for touchpad
'Mouse and touchpad settings' in System Settings provides no way to control r...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 13:01 EDT by Brion Vibber
Modified: 2016-09-22 18:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-22 18:46:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of mouse & touchpad settings (57.37 KB, image/png)
2015-08-12 13:01 EDT, Brion Vibber
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 757255 None None None 2016-09-22 18:46 EDT

  None (edit)
Description Brion Vibber 2015-08-12 13:01:25 EDT
Created attachment 1062116 [details]
Screenshot of mouse & touchpad settings

Description of problem:

Fedora 23 Alpha on MacBookPro 10,1; GNOME settings 'mouse & touchpad settings' screen doesn't provide any way to modify the right-click settings. Since this defaults to (apparently?) not providing right-click ability (bug 1252995) there's no user-visible way to modify the setting and get the computer in a "working" state.


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Boot Fedora 23 Alpha on MacBook Pro 10,1
2. Open 'System Settings'
3. Open 'Mouse and Touchpad'

Actual results:
No settings related to right-click emulation.

Expected results:
There should be a setting to control the right-click emulation for the touchpad.

Additional info:
Comment 1 Bastien Nocera 2016-09-22 18:46:10 EDT
By default, on Macs, the right-click is done by "clicking" with two-fingers.
If you don't like that, you can change it with:
gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

See also https://bugzilla.gnome.org/show_bug.cgi?id=757255

Note You need to log in before you can comment on or make changes to this bug.