Bug 1253006 - Reindex needs to handle bad errata and package/packagegroups etc
Reindex needs to handle bad errata and package/packagegroups etc
Status: CLOSED DUPLICATE of bug 1253010
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
http://projects.theforeman.org/issues...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 13:28 EDT by Bryan Kearney
Modified: 2017-02-23 14:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 14:29:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11140 None None None 2016-04-22 12:10 EDT

  None (edit)
Description Bryan Kearney 2015-08-12 13:28:58 EDT
The reindex task assumes that [Katello::Package, Katello::PuppetModule, Katello::Distribution, Katello::PackageGroup, Katello::Erratum] all have an "each" method in the case of on error. This causes an additional error thrown every time indexing one of those items fail. We just need to report the exception at the bulk level in those cases and not try to index one at a time. 

Also we need to handle errata that point to repo memberships that do not exist in katello (as in we need to ignore those associations). This can happen either when user directly create/syncs a private repo via pulp-admin OR deletes a repo and for some reason the membership did not get updated.
Comment 1 Bryan Kearney 2015-08-12 13:28:59 EDT
Created from redmine issue http://projects.theforeman.org/issues/11140
Comment 2 Bryan Kearney 2015-08-12 13:29:01 EDT
Upstream bug assigned to paji@redhat.com
Comment 4 Bryan Kearney 2015-08-12 14:29:53 EDT

*** This bug has been marked as a duplicate of bug 1253010 ***

Note You need to log in before you can comment on or make changes to this bug.