Bug 1253030 - python3-dnf TypeError: unsupported operand type(s) for -=: 'set' and 'map'
python3-dnf TypeError: unsupported operand type(s) for -=: 'set' and 'map'
Status: CLOSED DUPLICATE of bug 1252032
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 14:55 EDT by Vinson Lee
Modified: 2015-08-12 19:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 19:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vinson Lee 2015-08-12 14:55:39 EDT
Description of problem:


Version-Release number of selected component (if applicable):
python3-dnf-1.1.0-1.fc24.noarch

How reproducible:
100% 

Steps to Reproduce:
1. dnf update
2.
3.

Actual results:
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 146, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 168, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 165, in do_transaction
    pkg_str = self.output.list_transaction(trans)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1024, in list_transaction
    for pkg in self._skipped_broken_deps(skipped_conflicts):
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 947, in _skipped_broken_deps
    goal_diff -= skipped_conflicts
TypeError: unsupported operand type(s) for -=: 'set' and 'map'


Expected results:


Additional info:
Comment 1 Vinson Lee 2015-08-12 19:57:00 EDT

*** This bug has been marked as a duplicate of bug 1252032 ***

Note You need to log in before you can comment on or make changes to this bug.