Bug 1253044 - [abrt] dnf: output.py:947:_skipped_broken_deps:TypeError: unsupported operand type(s) for -=: 'set' and 'map'
[abrt] dnf: output.py:947:_skipped_broken_deps:TypeError: unsupported operand...
Status: CLOSED DUPLICATE of bug 1252032
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0f498fd3687cd52700fc5d522ec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 15:44 EDT by Алексей Смирнов
Modified: 2015-08-12 22:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 22:48:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.28 KB, text/plain)
2015-08-12 15:44 EDT, Алексей Смирнов
no flags Details
File: environ (1.90 KB, text/plain)
2015-08-12 15:44 EDT, Алексей Смирнов
no flags Details

  None (edit)
Description Алексей Смирнов 2015-08-12 15:44:22 EDT
Description of problem:
Just run "sudo dnf update" in the terminal.

Version-Release number of selected component:
dnf-1.1.0-1.fc24

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python3 -OO /bin/dnf update
executable:     /bin/dnf
kernel:         4.2.0-0.rc6.git0.1.fc24.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
output.py:947:_skipped_broken_deps:TypeError: unsupported operand type(s) for -=: 'set' and 'map'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 146, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 168, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 165, in do_transaction
    pkg_str = self.output.list_transaction(trans)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1024, in list_transaction
    for pkg in self._skipped_broken_deps(skipped_conflicts):
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 947, in _skipped_broken_deps
    goal_diff -= skipped_conflicts
TypeError: unsupported operand type(s) for -=: 'set' and 'map'

Local variables in innermost frame:
goal_diff: set()
skipped_conflicts: <map object at 0x7fb4b9aa5e10>
self: <dnf.cli.output.Output object at 0x7fb4ba6bbba8>
Comment 1 Алексей Смирнов 2015-08-12 15:44:26 EDT
Created attachment 1062199 [details]
File: backtrace
Comment 2 Алексей Смирнов 2015-08-12 15:44:27 EDT
Created attachment 1062200 [details]
File: environ
Comment 3 Parag Nemade 2015-08-12 22:48:28 EDT

*** This bug has been marked as a duplicate of bug 1252032 ***

Note You need to log in before you can comment on or make changes to this bug.