This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253055 - Xorg log does not exist in RHEL 7.2
Xorg log does not exist in RHEL 7.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
: 1255913 (view as bug list)
Depends On:
Blocks: 1190227
  Show dependency treegraph
 
Reported: 2015-08-12 16:36 EDT by Swapna Krishnan
Modified: 2015-11-19 02:16 EST (History)
3 users (show)

See Also:
Fixed In Version: gdm-3.14.2-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:16:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Swapna Krishnan 2015-08-12 16:36:32 EDT
Description of problem:
There's no Xorg logs in RHEL 7.2 in /var/log. However, display driver messages are present in /var/log/messages

Version-Release number of selected component (if applicable):
xorg-x11-drv-qxl-0.1.1-16.el7.x86_64
gdm-3.14.2-10.el7.x86_64
xorg-x11-server-Xorg-1.17.2-5.el7.x86_64

How reproducible:
100%
Comment 2 Tomas Pelka 2015-08-13 02:59:14 EDT
My guess it is because 

root      1798  0.0  0.8 431784 104684 tty1    Ssl+ Aug11   2:12 /usr/bin/Xorg :0 -background none -noreset -audit 4 -verbose 3 -logfile /dev/null -auth /run/gdm/auth-for-gdm-oTTj9L/database -seat seat0 -nolisten tcp vt1

Is it expected Xorg is running with "-logfile /dev/null"
Comment 3 Ray Strode [halfline] 2015-08-13 11:15:57 EDT
it was an intentional upstream change to move X logging to the journal.  The journal gets mirrored to /var/log/messages by rsyslog in RHEL7 (but we don't use rsyslog in recent versions of fedora).

Whether or not we should keep 7.2 like this, I'm not completely sure.  Customers might get thrown off by the logs moving.  Also in RHEL 6, customers complained when certain GDM logs ended up in syslog ( see bug 834303 )

So I'm thinking we should probably change the logs back to the same locations as 7.1 to be conservative and customer friendly.
Comment 5 Ray Strode [halfline] 2015-08-25 11:43:45 EDT
*** Bug 1255913 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2015-11-19 02:16:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.