Bug 1253056 - DRBD userland needs upstream 8.9.3-2 for pacemaker integration fix
DRBD userland needs upstream 8.9.3-2 for pacemaker integration fix
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: drbd (Show other bugs)
22
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Major Hayden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 16:36 EDT by Ken Gaillot
Modified: 2015-08-22 20:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.9.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-22 13:36:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Gaillot 2015-08-12 16:36:38 EDT
Description of problem: The drbd tools' upstream 8.9.3 release used in Fedora 22 has a bug in the pacemaker integration script. The upstream 8.9.3-2 release is said to have the fix.

Version-Release number of selected component (if applicable): 8.9.3-1.fc22

How reproducible: Configure a DRBD resource in Pacemaker on Fedora 22


Steps to Reproduce:
1. On two Fedora 22 hosts: dnf install pacemaker pcs drbd-udev drbd-pacemaker
2. Configure a pacemaker cluster and DRBD volume on both hosts.
3. Configure a DRBD resource, for example: pcs resource create testresource ocf:linbit:drbd drbd_resource=dbrdvolume op monitor interval=60s && pcs resource master testclone testresource master-max=1 master-node-max=1 clone-max=2 clone-node-max=1 notify=true

Actual results: Resource fails to start, and system log shows: "drbdadm: Unknown command 'syncer'"

Expected results: Resource starts successfully

Additional info: This is the same issue reported in http://www.gossamer-threads.com/lists/drbd/users/27316 for CentOS 7
Comment 1 Major Hayden 2015-08-12 17:29:48 EDT
Thanks for bringing this up, Ken.  It looks like the DRBD folks haven't cut a release for this quite yet:

  http://git.drbd.org/gitweb.cgi?p=drbd-utils.git;a=summary

The 8.9.3 tarball is unaltered.  I'll see if I can get a new build rolling later tonight for you to test.
Comment 2 Ken Gaillot 2015-08-13 13:05:16 EDT
Thanks. FYI I confirmed that using the latest upstream drbd.ocf (http://git.linbit.com/gitweb.cgi?p=drbd-utils.git;a=blob_plain;f=scripts/drbd.ocf;h=cf6b966341377a993d1bf5f585a5b9fe72eaa5f2;hb=c11ba026bbbbc647b8112543df142f2185cb4b4b) as /usr/lib/ocf/resource.d/linbit/drbd fixes the issue.
Comment 3 Major Hayden 2015-08-13 16:14:29 EDT
Here's something to test:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=677206

Let me know if that works.
Comment 4 Fedora Update System 2015-08-13 16:17:22 EDT
drbd-8.9.3-2.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/drbd-8.9.3-2.fc23
Comment 5 Fedora Update System 2015-08-13 16:18:11 EDT
drbd-8.9.3-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/drbd-8.9.3-2.fc22
Comment 6 Fedora Update System 2015-08-13 16:42:33 EDT
drbd-8.9.3-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/drbd-8.9.3-2.fc21
Comment 7 Ken Gaillot 2015-08-13 17:20:39 EDT
I can confirm those packages work. Thanks for the quick response! :)
Comment 8 Major Hayden 2015-08-13 17:47:56 EDT
SWEET! Just waiting on bodhi now. ;)

If possible, could you please leave karma in Bodhi for this update?

  https://admin.fedoraproject.org/updates/drbd-8.9.3-2.fc22
Comment 9 Fedora Update System 2015-08-14 22:18:23 EDT
Package drbd-8.9.3-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing drbd-8.9.3-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13495/drbd-8.9.3-2.fc21
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2015-08-22 13:36:08 EDT
drbd-8.9.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-08-22 18:49:52 EDT
drbd-8.9.3-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-08-22 20:48:13 EDT
drbd-8.9.3-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.