Bug 1253074 - rhsm_ks.py traceback
rhsm_ks.py traceback
Status: CLOSED DUPLICATE of bug 1150150
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 17:58 EDT by Brian Lane
Modified: 2015-08-13 17:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 17:19:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2015-08-12 17:58:02 EDT
rhsm_ks.py has this code:

    def setup(self, storage, ksdata, instclass):
        super(RHSMAddonData, self).__init__(storage, ksdata, instclass)

It should actually be calling setup, not __init__:

super(RHSMAddonData, self).setup(storage, ksdata, instclass)
Comment 3 Adrian Likins 2015-08-13 17:19:22 EDT

*** This bug has been marked as a duplicate of bug 1150150 ***

Note You need to log in before you can comment on or make changes to this bug.