Bug 1253108 - Attach-disk should forbid "--iothread = 0 "
Summary: Attach-disk should forbid "--iothread = 0 "
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: John Ferlan
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-13 01:50 UTC by Pei Zhang
Modified: 2015-11-19 06:51 UTC (History)
6 users (show)

Fixed In Version: libvirt-1.2.17-6.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Pei Zhang 2015-08-13 01:50:10 UTC
Description of problem:
When we attach a disk to guest with iothread , the iothreadid cannot be 0 , it is invalid.but attach disk won't forbid it.

Version-Release number of selected component (if applicable):
libvirt-1.2.17-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. define and start a heathy guest with iothreads,like following :
 <iothreads>4</iothreads>

2. try to attach a disk to guest with iothread = 0 

# virsh attach-disk r7-vm1 /var/lib/libvirt/images/qcow2.img vdb --subdriver qcow2 --iothread 0
Disk attached successfully

chech domain xml , it no iothread in <driver>

#virsh dumpxml r7-vm1 
 <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/qcow2.img'/>
      <backingStore/>
      <target dev='vdb' bus='virtio'/>
      <alias name='virtio-disk1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0b' function='0x0'/>
    </disk>

3.using iothreadadd to add iothread id=0 , it is invalid.

# virsh iothreadadd r7-vm1 --id 0
error: Invalid IOThread id value: '0'

Actual results :
As step2 , iothread = 0 can be attached 

Expected resutls :
Libvirt should forbid it .

Additional info :

Comment 4 Han Han 2015-09-11 07:30:45 UTC
Hi John, I can reproduce it on libvirt-1.2.17-4.el7.x86_64
Verify it on libvirt-1.2.17-8.el7.x86_64


Steps to Verify:
1. Define a domain which has os, with xml following:
...
<iothreads>4</iothreads>
...
# virsh iothreadinfo t38
 IOThread ID     CPU Affinity   
---------------------------------------------------
 1               0-7
 2               0-7
 3               0-7
 4               0-7

2. Start domain and attach-disk with --iothread 0 option
# virsh start t38                         
Domain t38 started

# virsh attach-disk t38 /var/lib/libvirt/images/test.qcow2 vdb --iothread 0 --config
error: Failed to attach disk
error: XML error: Invalid iothread attribute in disk driver element: 0

virsh attach-disk t38 /var/lib/libvirt/images/test.qcow2 vdb --iothread 0         
error: Failed to attach disk
error: XML error: Invalid iothread attribute in disk driver element: 0

Comment 6 errata-xmlrpc 2015-11-19 06:51:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.