This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253109 - createrepo_c won't generate xz compressed XML metadata with --xz or --compress-type=xz
createrepo_c won't generate xz compressed XML metadata with --xz or --compres...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: createrepo_c (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-12 22:09 EDT by Neal Gompa
Modified: 2015-08-14 05:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 05:29:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Gompa 2015-08-12 22:09:11 EDT
Description of problem:
When using createrepo_c to create repodata that is xz-compressed, it goes ahead and creates gz compressed XML metadata anyway. If I am creating SQLite data too, that data is compressed the way I want it to be, but the XML data is not.

Version-Release number of selected component (if applicable):
createrepo_c-0.9.0-3.fc22

How reproducible:
Always

Steps to Reproduce:
1. Create a folder with some RPMs
2. Run one of the following:
   * createrepo_c --no-database --compress-type=xz <path/to/folder>
   * createrepo_c --database --compress-type=xz <path/to/folder>
   * createrepo_c --no-database --xz <path/to/folder>
   * createrepo_c --database --xz <path/to/folder>

Actual results:
The repodata subfolder contains gz-compressed XML data.

Expected results:
The repodata subfolder contains xz-compressed XML data.

Additional info:
N/A
Comment 1 Tomas Mlcoch 2015-08-14 05:29:28 EDT
Hi Neal,
this is because of compatibility with createrepo.
I don't like it either, but createrepo does exactly the same thing and because createrepo_c is supposed to be drop-in replacement and thus preserve such illogical behaviour.
Maybe I could add some kind of new command line option or something.
Feel free to open an RFE with ideal of how you would like to see this behave.

Note You need to log in before you can comment on or make changes to this bug.