Bug 1253120 - dnf remove: when remove multiple versions of kernel packages, the "Erasing" result of "Running transaction" show duplicated lowest version number
Summary: dnf remove: when remove multiple versions of kernel packages, the "Erasing" r...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 23
Hardware: Unspecified Unspecified
low
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Triaged
: 1286273 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-13 03:49 UTC by LiuYan
Modified: 2016-10-04 18:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 18:07:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf remove multiple kernel versions.txt (3.20 KB, text/plain)
2015-08-13 03:49 UTC, LiuYan
no flags Details

Description LiuYan 2015-08-13 03:49:00 UTC
Created attachment 1062327 [details]
dnf remove multiple kernel versions.txt

Description of problem:
When use `dnf remove` to remove multiple versions of kernel packages, the "Erasing" lines of "Running transaction" show duplicated lowest version number


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1. use `dnf remove` to remove multiple versions of kernel packages, such as `dnf remove  *-4.1.3-201.fc22  *-4.1.4-200.fc22`
2. see the "Erasing .." lines of "Running trasaction" messages
3. there're duplicated "Erasing..." lines, the version number in "Erasing..." lines are all the lowest version of kernel package specified in `dnf remove` packages.

Actual results:

========================================================================================================================
......
Running transaction
  Erasing     : kernel-4.1.3-201.fc22.x86_64                                                                        1/6 
  Erasing     : kernel-4.1.3-201.fc22.x86_64                                                                        2/6 
  Erasing     : kernel-modules-4.1.3-201.fc22.x86_64                                                                3/6 
  Erasing     : kernel-modules-4.1.3-201.fc22.x86_64                                                                4/6 
  Erasing     : kernel-core-4.1.3-201.fc22.x86_64                                                                   5/6 
  Erasing     : kernel-core-4.1.3-201.fc22.x86_64                                                                   6/6 
  Verifying   : ......
......
========================================================================================================================


Expected results:

========================================================================================================================
......
Running transaction
  Erasing     : kernel-4.1.3-201.fc22.x86_64                                                                        1/6 
  Erasing     : kernel-4.1.4-200.fc22.x86_64                                                                        2/6 
  Erasing     : kernel-modules-4.1.3-201.fc22.x86_64                                                                3/6 
  Erasing     : kernel-modules-4.1.4-200.fc22.x86_64                                                                4/6 
  Erasing     : kernel-core-4.1.3-201.fc22.x86_64                                                                   5/6 
  Erasing     : kernel-core-4.1.4-200.fc22.x86_64                                                                   6/6 
  Verifying   : ......
......
========================================================================================================================


Additional info:

Comment 1 Honza Silhan 2015-08-19 11:19:17 UTC
Thanks for the report.

Comment 2 Mat Booth 2015-11-12 10:02:19 UTC
This bug is still present in F23 with the following version of DNF:

$ rpm -qa | grep ^dnf | sort                        
dnf-1.1.3-1.fc23.noarch
dnf-conf-1.1.3-1.fc23.noarch
dnf-plugins-core-0.1.13-1.fc23.noarch
dnf-plugin-system-upgrade-0.7.0-1.fc23.noarch
dnf-yum-1.1.3-1.fc23.noarch

Comment 3 Michal Domonkos 2015-11-30 12:31:40 UTC
*** Bug 1286273 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Admin XMLRPC Client 2016-07-08 09:37:57 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.