Bug 1253163 - [Virtio 1.0] Memory balloon device does not work after migration unless a reboot
[Virtio 1.0] Memory balloon device does not work after migration unless a reboot
Status: CLOSED DUPLICATE of bug 1243750
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
All Unspecified
medium Severity medium
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 03:16 EDT by Qunfang Zhang
Modified: 2015-08-14 02:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 02:15:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2015-08-13 03:16:09 EDT
Description of problem:
Boot up a RHEL7.2 guest with virtio-ballloon-pci with virtio 1.0 parameter, migrate guest to the destination host, and then balloon the guest memory. The value does not change. If I reboot the guest, the memory balloon with enlarge or shrink to the target value.  Test without virtio 1.0, the issue does not exist. 

Version-Release number of selected component (if applicable):
ppc64le:
Host:
kernel-3.10.0-302.el7.ppc64le
qemu-kvm-rhev-2.3.0-16.el7.ppc64le
Guest: 
kernel-3.10.0-300.el7.ppc64le

x86:
Host: 
kernel-3.10.0-300.el7.x86_64
qemu-kvm-rhev-2.3.0-16.el7.x86_64

Guest:
kernel-3.10.0-304.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot up a guest with virtio-balloon (virtio 1.0)

 /usr/libexec/qemu-kvm -name qzhang_test -machine pc -m 8G -smp 4,sockets=2,cores=1,threads=2 -uuid 8aeab7e2-f341-4f8c-80e8-59e2968d85c2 -realtime mlock=off -nodefaults -monitor stdio -rtc base=utc -device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 -drive file=RHEL-Server-7.2-64-virtio.qcow2,if=none,id=drive-scsi0-0-0-0,format=qcow2,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi0-0-0-0,bootindex=1,id=scsi0-0-0-0  -drive if=none,id=drive-scsi0-0-1-0,readonly=on,format=raw -device scsi-cd,bus=scsi0.0,drive=drive-scsi0-0-1-0,bootindex=2,id=scsi0-0-1-0 -vnc :15 -msg timestamp=on -usb -device usb-tablet,id=tablet1  -vga std -qmp tcp:0:4666,server,nowait -netdev tap,id=hostnet1,script=/etc/qemu-ifup,vhost=on -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:54:5a:5f:5b:5c -device virtio-balloon-pci,bus=pci.0,addr=0x9,id=balloon0,disable-legacy=on,disable-modern=off


2. Boot the guest on destination host with "-incoming tcp:0:5800"

3. Balloon the guest memory:
(qemu) info balloon
balloon: actual=8192
(qemu) balloon 4096
(qemu) info balloon (after 3~5s)
balloon: actual=4096 

4.Migrate guest to destination host:
(qemu) migrate -d tcp:0:5800

6. On destination host:
(qemu)  info balloon
balloon: actual=4096 

7. On destination host:
(qemu)balloon 8000
(qemu)info balloon
balloon: actual=4096 

8. Reboot guest

9.  On destination host:
(qemu)info balloon
balloon: actual=8000

Actual results:
Memory balloon device does not work after migration unless a reboot

Expected results:
Memory balloon device should work after migration

Additional info:
Comment 4 jason wang 2015-08-14 02:15:29 EDT

*** This bug has been marked as a duplicate of bug 1243750 ***

Note You need to log in before you can comment on or make changes to this bug.