Bug 1253165 - glusterd services are not handled properly when re configuring services
glusterd services are not handled properly when re configuring services
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.3
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Anand Nekkunti
: Triaged
Depends On: 1209329
Blocks: 1221869 1230532
  Show dependency treegraph
 
Reported: 2015-08-13 03:21 EDT by Anand Nekkunti
Modified: 2016-01-03 23:50 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1209329
Environment:
Last Closed: 2015-09-09 05:39:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nekkunti 2015-08-13 03:21:07 EDT
+++ This bug was initially created as a clone of Bug #1209329 +++

Description of problem:

When doing a volume set or reset on a volume, all the glusterfs services will be restarted. But if quota daemon is not enabled, then BitD deamon will fail to reconfigure.

Version-Release number of selected component (if applicable):


How reproducible:

1/1

Steps to Reproduce:
1.create and start a volume.
2.Enable BitD daemon
3.Disable quota daemon
4.do a reset for this volume (gluster volume reset vol)

Actual results:

BitD still running

Expected results:

BitD should show the default behavior after a volume reset 

Additional info:

<snip from xlators/mgmt/glusterd/src/glusterd-svc-helper.c >

 49         if (volinfo && !glusterd_is_volume_quota_enabled (volinfo))
 50                 goto out;
 51 
 52         ret = glusterd_quotadsvc_reconfigure ();
 53         if (ret)
 54                 goto out;
 55 
 56         ret = glusterd_bitdsvc_reconfigure ();
 57         if (ret)
 58                 goto out;
 59 
 60         ret = glusterd_scrubsvc_reconfigure ();
 61         if (ret)
 62                 goto out;

--- Additional comment from Anand Avati on 2015-04-07 06:33:15 EDT ---

REVIEW: http://review.gluster.org/10149 (glusterd: bitd daemon should stop after doing volume reset <volname> force) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Anand Avati on 2015-04-07 07:04:51 EDT ---

REVIEW: http://review.gluster.org/10149 (glusterd: bitd daemon should stop after doing volume reset <volname> force) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)

--- Additional comment from Mohammed Rafi KC on 2015-04-09 08:15:46 EDT ---

Changing the summary because this bug is also existing for quota,bitd,scrub,shd.

--- Additional comment from Anand Avati on 2015-04-09 08:30:44 EDT ---

REVIEW: http://review.gluster.org/10177 (glusterd: Modify reconfigure function for glusterd services) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-05-14 07:15:25 EDT ---

REVIEW: http://review.gluster.org/10783 (glusterd: Stop or restart svc services during reset on a volume.) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-14 15:12:03 EDT ---

REVIEW: http://review.gluster.org/10783 (glusterd: Stop or restart svc services during reset on a volume.) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-20 09:38:37 EDT ---

REVIEW: http://review.gluster.org/10847 (glusterd: Stop/restart svc services during reset on a volume.) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-20 10:25:16 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart svc services during reset on a volume) posted (#1) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 03:51:51 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart svc services during reset on a volume) posted (#2) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 05:46:14 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart svc services during reset/set on a volume) posted (#3) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 08:42:56 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart svc services during reset on a volume) posted (#4) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-21 23:51:59 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart svc services during reset on a volume) posted (#5) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-23 15:16:53 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#6) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-24 03:49:04 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#7) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-24 05:27:26 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#8) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-25 12:38:42 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#9) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-25 22:39:47 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#10) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-26 10:30:05 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#11) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-27 23:37:58 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#12) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 06:20:36 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#13) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-29 02:26:37 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#14) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-05-30 00:24:10 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#15) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-01 02:19:53 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#16) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-10 16:08:36 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#18) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-06-17 09:12:52 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#20) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-07-13 02:43:27 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#21) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-07-22 09:48:39 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#24) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-07-23 11:41:57 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#25) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-07-30 03:13:03 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#26) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-08-03 07:52:39 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#27) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-08-06 00:16:34 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#28) for review on master by Anand Nekkunti (anekkunt@redhat.com)

--- Additional comment from Anand Avati on 2015-08-06 08:15:56 EDT ---

REVIEW: http://review.gluster.org/10850 (glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume) posted (#29) for review on master by Anand Nekkunti (anekkunt@redhat.com)
Comment 1 Avra Sengupta 2015-08-18 05:57:16 EDT
Patch present at http://review.gluster.org/#/c/11905/
Comment 2 Anand Avati 2015-08-18 06:58:33 EDT
COMMIT: http://review.gluster.org/11905 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit c49b8064bd83a512dd962d4c4168728886ff0a5c
Author: anand <anekkunt@redhat.com>
Date:   Wed May 20 19:52:11 2015 +0530

    glusterd: Stop/restart/notify to daemons(svcs) during reset/set on a volume
    
    problem : Reset/set commands were not working properly. reset command returns
    success but it not sending notification to svcs if corresponding graph modified.
    
    Fix: Whenever reset/set command issued, generate the temp graph and compare
    with original graph and do the fallowing actions
    1.) If both graph are identical nothing to do with svcs.
    2.) If any changes in graph topology restart/stop service by calling
    svc manager.
    3)  If changes in options send notify signal by calling glusterd_fetchspec_notify.
    
    Back port of:
    >Change-Id: I852c4602eafed1ae6e6a02424814fe3a83e3d4c7
    >BUG: 1209329
    >Signed-off-by: anand <anekkunt@redhat.com>
    >Reviewed-on: http://review.gluster.org/10850
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    >(cherry picked from commit 7255febab2c38cc89b71f2519a20d10f53586000)
    
    Change-Id: I42aa757ecc6b5b307b5927d11f12d08f57ac0ae2
    BUG: 1253165
    Reviewed-on: http://review.gluster.org/11905
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Kaushal 2015-09-09 05:39:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.