Bug 1253192 - dnf update fails with last update to
dnf update fails with last update to
Status: CLOSED DUPLICATE of bug 1252032
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 04:02 EDT by Dodji Seketeli
Modified: 2015-08-13 04:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 04:03:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dodji Seketeli 2015-08-13 04:02:05 EDT
After my last dnf update in rawhide, dnf update now fails on me with:


dodji@paname:~$ sudo dnf update
Last metadata expiration check performed 6:40:19 ago on Thu Aug 13 03:10:46 2015.
Dependencies resolved.
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 193, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 146, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 168, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 165, in do_transaction
    pkg_str = self.output.list_transaction(trans)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 1024, in list_transaction
    for pkg in self._skipped_broken_deps(skipped_conflicts):
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 947, in _skipped_broken_deps
    goal_diff -= skipped_conflicts
TypeError: unsupported operand type(s) for -=: 'set' and 'map'
dodji@paname:~$ 

This leaves me with a system that I cannot upgrade anymore.

The current version of dnf on my system is:

Name        : dnf
Arch        : noarch
Epoch       : 0
Version     : 1.1.0
Release     : 1.fc24
Size        : 699 k
Repo        : @System
Summary     : Package manager forked from Yum, using libsolv as a dependency resolver
URL         : https://github.com/rpm-software-management/dnf
License     : GPLv2+ and GPLv2 and GPL
Description : Package manager forked from Yum, using libsolv as a dependency resolver.
Comment 1 Parag Nemade 2015-08-13 04:03:43 EDT
Please use new update http://koji.fedoraproject.org/koji/buildinfo?buildID=677061

*** This bug has been marked as a duplicate of bug 1252032 ***

Note You need to log in before you can comment on or make changes to this bug.