Bug 1253199 - Guest show "state": 0 and "active": 0 when suspend guest in hyperv
Guest show "state": 0 and "active": 0 when suspend guest in hyperv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
xingge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 04:26 EDT by Liushihui
Modified: 2016-11-30 19:33 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.14-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:57:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-08-13 04:26:12 EDT
Description of problem:
Suspend guest on hyperv, check the guest's "active" and "status", it shows "state": 0 and "active": 0

Version-Release number of selected component (if applicable):
virt-who-0.14-3.el7.noarch
subscription-manager-1.15.9-2.el7.x86_64
python-rhsm-1.15.4-2.el7.x86_64
Satellite 6.1.0-20150731.0

How reproducible:
Always

Steps to Reproduce:
1.Register system to satellite, start guest.
2.Configure virt-who run at hyperv mode and restart virt-who service
[root@hp-z220-07 libvirt-test-API]# cat /etc/sysconfig/virt-who  | grep -v ^# | grep -v ^$
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
VIRTWHO_HYPERV=1
VIRTWHO_HYPERV_OWNER=ACME_Corporation
VIRTWHO_HYPERV_ENV=Library
VIRTWHO_HYPERV_SERVER=10.66.128.9
VIRTWHO_HYPERV_USERNAME=administrator
VIRTWHO_HYPERV_PASSWORD=qwer1234P
3.Check virt-who's log
        {
            "guestId": "E2EC00E1-5022-2341-93FF-CD68A7BF0324", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv"
            }
        }
4. Suspend guest, then check virt-who service
        {
            "guestId": "E2EC00E1-5022-2341-93FF-CD68A7BF0324", 
            "state": 0, ========================= It should be "3"
            "attributes": {
                "active": 0, ==================== It should be "1"
                "virtWhoType": "hyperv"
            }
        }, 

Actual results:
After suspend guest, both "active" and "state" are "0"

Expected results:
After suspend guest, The value of "active" should be "1" , the value of "state" should be "3". 

Additional info:
Comment 1 Radek Novacek 2015-08-18 11:57:01 EDT
Fixed in virt-who-0.14-4.el7.
Comment 3 Liushihui 2015-08-24 02:22:51 EDT
Verified it on virt-who-0.14-4.el7.noarch since guest show "active" is "1" , the value of "state" is "3"

Verified version
virt-who-0.14-4.el7.noarch
subscription-manager-1.15.9-6.el7.x86_64
python-rhsm-1.15.4-2.el7.x86_64

Verified process:
1.Register system to satellite, start guest.
2.Configure virt-who run at hyperv mode and restart virt-who service
[root@hp-z220-07 libvirt-test-API]# cat /etc/sysconfig/virt-who  | grep -v ^# | grep -v ^$
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
VIRTWHO_HYPERV=1
VIRTWHO_HYPERV_OWNER=ACME_Corporation
VIRTWHO_HYPERV_ENV=Library
VIRTWHO_HYPERV_SERVER=10.66.128.9
VIRTWHO_HYPERV_USERNAME=administrator
VIRTWHO_HYPERV_PASSWORD=qwer1234P
3.Check virt-who's log
        {
            "guestId": "E2EC00E1-5022-2341-93FF-CD68A7BF0324", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv"
            }
        }
4. Suspend guest, then check virt-who service
        {
            "guestId": "EE94C539-CA59-8447-AB31-691E22C2814D", 
            "state": 3, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "hyperv", 
                "hypervisorType": "hyperv"
            }
        }
    ]
}

Results:
After suspend guest,guest's "active": 1 and "state": 3
Comment 4 errata-xmlrpc 2015-11-19 06:57:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2370.html

Note You need to log in before you can comment on or make changes to this bug.