Bug 1253200 - qemu core dump after lvextend several times
Summary: qemu core dump after lvextend several times
Keywords:
Status: CLOSED DUPLICATE of bug 1277922
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-13 08:26 UTC by quxiaoya
Modified: 2015-11-20 13:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-20 13:29:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description quxiaoya 2015-08-13 08:26:28 UTC
Description of problem:

install kvm guest on lvm with small disk size, and extend lvm disk size when vm pause on no space several times. every times need to continue vm. After execute that qemu will core dumped

Version-Release number of selected component (if applicable):

host info:
# uname -r
3.10.0-304.el7.x86_64
# rpm -qa | grep qemu
qemu-kvm-rhev-2.3.0-16.el7.x86_64

How reproducible:
100%
Steps to Reproduce:
1. create lvm in host
# lvcreate -n lvtest -L 4M vg1

2. Create a large enough qcow2 file on lvm
#qemu-img create -f qcow2 /dev/vg1/lvtest 80G
3.
# gdb /usr/libexec/qemu-kvm

(gdb) run -m 4G -smp 4 -M pc-i440fx-rhel7.2.0 -boot menu=on -drive file=/dev/vg1/lvtest,format=qcow2,if=none,id=img,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,id=scsi1,bus=pci.0,addr=0x8,drive=img -monitor stdio -spice port=5934,disable-ticketing -netdev tap,id=tap0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=tap0,mac=22:be:05:14:95:16 -qmp tcp::8887,server,nowait -kernel /home/vmlinuz -initrd /home/initrd.img -append method=http://download.englab.nay.redhat.com/pub/rhel/nightly/latest-RHEL-7/compose/Server/x86_64/os/ 

4  extend the lvm  until vm pause on no space
# lvextend -L +50M /dev/vg1/lvtest

5  in qmp monitor . issue cont
qmp : {"execute":"cont"}

6 repeat 4-5 several times

Actual results:
(gdb) bt
#0  0x00007ffff3c2735a in tcmalloc::ThreadCache::ReleaseToCentralCache(tcmalloc::ThreadCache::FreeList*, unsigned long, int) () from /lib64/libtcmalloc.so.4
#1  0x00007ffff3c276b0 in tcmalloc::ThreadCache::Scavenge() () from /lib64/libtcmalloc.so.4
#2  0x00007ffff3c36057 in tc_free () from /lib64/libtcmalloc.so.4
#3  0x00007ffff64cf36f in g_free () from /lib64/libglib-2.0.so.0
#4  0x00007ffff64e5a79 in g_slice_free1 () from /lib64/libglib-2.0.so.0
#5  0x000055555563102e in virtio_blk_free_request (req=0x55556174e000)
    at /usr/src/debug/qemu-2.3.0/hw/block/virtio-blk.c:45
#6  virtio_blk_rw_complete (opaque=<optimized out>, ret=0)
    at /usr/src/debug/qemu-2.3.0/hw/block/virtio-blk.c:121
#7  0x00005555557df26e in bdrv_co_em_bh (opaque=0x555556999500) at block.c:4981
#8  0x00005555557d8464 in aio_bh_poll (ctx=ctx@entry=0x5555569d4840) at async.c:85
#9  0x00005555557e7660 in aio_dispatch (ctx=0x5555569d4840) at aio-posix.c:137
#10 0x00005555557d82de in aio_ctx_dispatch (source=<optimized out>, 
    callback=<optimized out>, user_data=<optimized out>) at async.c:219
#11 0x00007ffff64c979a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#12 0x00005555557e62c8 in glib_pollfds_poll () at main-loop.c:200
#13 os_host_main_loop_wait (timeout=<optimized out>) at main-loop.c:245
#14 main_loop_wait (nonblocking=<optimized out>) at main-loop.c:494
#15 0x00005555555e4a0e in main_loop () at vl.c:1800
#16 main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4375

Expected results:

qemu works well and install guest successfully

Additional info:

Comment 4 Paolo Bonzini 2015-11-20 13:29:51 UTC

*** This bug has been marked as a duplicate of bug 1277922 ***


Note You need to log in before you can comment on or make changes to this bug.