Bug 1253215 - Template creation of VM+qcow2 disk failure
Template creation of VM+qcow2 disk failure
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Maor
Ori Gofen
storage
: Regression
Depends On: 1264677
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 04:59 EDT by Ori Gofen
Modified: 2016-03-10 10:11 EST (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:40:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine.log (232.04 KB, text/plain)
2015-08-13 04:59 EDT, Ori Gofen
no flags Details

  None (edit)
Description Ori Gofen 2015-08-13 04:59:20 EDT
Created attachment 1062407 [details]
engine.log

Description of problem:
When trying to create a template from a VM with qcow2 disk, The operation fails on ui but succeed de facto.
a pop up window explains:

"Error while executing action New VM Template: This operation is currently blocked due to the status of the Image file.
The Image file status is transient (probably locked by another parallel operation). Please wait for the status to clear and try again."

engine log:
2015-08-13 11:43:57,331 ERROR [org.ovirt.engine.core.bll.AddVmTemplateCommand] (default task-63) [765f3a71] Command 'org.ovirt.engine.core.bll.AddVmTemplateCommand' failed: EngineException: IRS_IMAGE_STATUS_ILLEGAL (Failed with error IRS_IMAGE_STATUS_ILLEGAL and code 5006)
2015-08-13 11:43:57,337 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-63) [765f3a71] Correlation ID: 765f3a71, Job ID: 88f52b22-f2f4-4fd7-8962-8610bd3078bd, Call Stack: null, Custom Event ID: -1, Message: Failed to complete creation of Template t2 from VM vm_qcow_2.
 
Version-Release number of selected component (if applicable):
3.6

How reproducible:
100%

Steps to Reproduce:
1.have a vm+qcow disk
2.open "New Template" dialogue
3.tab browse to 'ok' button
4. press ok

Actual results:
Operation Fails on UI

Expected results:
Operation UI status should be in correlation with the backend 

Additional info:
Comment 1 Allon Mureinik 2015-08-13 06:58:39 EDT
The log is full with hibernate errors, which is probably the real problem here, and not the template creation.
Maor - please take a look?
Comment 2 Maor 2015-09-08 03:44:47 EDT
It looks like an infra issue which should be fixed already:
 "A collection with cascade="all-delete-orphan" was no longer referenced by the owning entity instance: org.ovirt.engine.core.common.job.Job.steps"
Ori, does it still reproduce with the new QE build.
Comment 3 Allon Mureinik 2015-09-13 06:58:45 EDT
(In reply to Maor from comment #2)
> It looks like an infra issue which should be fixed already:
>  "A collection with cascade="all-delete-orphan" was no longer referenced by
> the owning entity instance: org.ovirt.engine.core.common.job.Job.steps"
> Ori, does it still reproduce with the new QE build.

This is indeed a regression on the infra side, that should have been fixed in the last build.
Returning to ON_QA for QA to verify.
Comment 4 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:54 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Ori Gofen 2015-10-27 10:02:24 EDT
Verfied on rhevm-3.6.0.2
Comment 6 Sandro Bonazzola 2015-11-04 08:40:56 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.