This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253243 - Firefox 40 randomly crashes
Firefox 40 randomly crashes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 06:16 EDT by Christian Klomp
Modified: 2015-08-14 12:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: 40.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 12:55:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
about:support information (3.53 KB, text/plain)
2015-08-13 06:16 EDT, Christian Klomp
no flags Details
back trace 1 (277.68 KB, text/plain)
2015-08-13 06:17 EDT, Christian Klomp
no flags Details
back trace 2 (296.02 KB, text/plain)
2015-08-13 06:18 EDT, Christian Klomp
no flags Details
back trace 3 (211.79 KB, text/plain)
2015-08-13 06:18 EDT, Christian Klomp
no flags Details
back trace 4 (220.00 KB, text/plain)
2015-08-13 06:19 EDT, Christian Klomp
no flags Details
back trace 5 (258.82 KB, text/plain)
2015-08-13 06:19 EDT, Christian Klomp
no flags Details
installed packages (5.79 KB, text/plain)
2015-08-13 06:20 EDT, Christian Klomp
no flags Details

  None (edit)
Description Christian Klomp 2015-08-13 06:16:39 EDT
Created attachment 1062437 [details]
about:support information

Probably duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1253086 but I am unable to attach my back traces to existing bugs.

Description of problem:
Since Firefox 39 I'm experiencing random crashes.
With Firefox 40 it seems a lot worse.

Version-Release number of selected component (if applicable):
40

How reproducible:
Normal browsing (reading pages, changing tabs, watching videos) but very random.
I.e. not (easily) reproducible.

Steps to acquire back traces:
1. Created new profile
2. Ran firefox in gdb: firefox -g -d gdb -P Bug -safe-mode -no-remote
3. Browsed a while until it crashed and followed steps on https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products

Additional info:
Flash or no flash doesn't seem to matter.
debuginfo was installed via dnf debuginfo install firefox, but gdm mentioned a lot of additional packages, yet dnf wouldn't install them (for some reason it hanged at the downloading stage).

My related mozilla bug reports since 39:
https://crash-stats.mozilla.com/report/index/bp-7e4513bb-c873-44e4-9070-f9d472150706
https://crash-stats.mozilla.com/report/index/bp-801deab7-a74a-4d9f-bd41-afc832150706
https://crash-stats.mozilla.com/report/index/bp-fbbef610-cd4a-4d02-877d-cadcf2150707
https://crash-stats.mozilla.com/report/index/bp-8d43de6d-aae8-4571-9c2d-d19642150717
https://crash-stats.mozilla.com/report/index/bp-d1b1c734-8d82-437d-a118-c5ea32150806
https://crash-stats.mozilla.com/report/index/bp-0ce3a64f-95ed-4364-8014-9595c2150806
https://crash-stats.mozilla.com/report/index/bp-efc47a68-18e7-48a2-a779-b93012150806
https://crash-stats.mozilla.com/report/index/bp-6748ad0a-d18d-4b6d-ab37-54c1f2150806
https://crash-stats.mozilla.com/report/index/bp-ec594328-9758-4bc6-b309-9dba32150812
https://crash-stats.mozilla.com/report/index/bp-9d268257-f70e-44f3-bf2a-d70da2150812
https://crash-stats.mozilla.com/report/index/bp-17a9b2bc-64b4-4a72-b573-ee7092150812
https://crash-stats.mozilla.com/report/index/bp-7319e6d8-644f-45b8-8d64-1c8422150813
Comment 1 Christian Klomp 2015-08-13 06:17:37 EDT
Created attachment 1062438 [details]
back trace 1
Comment 2 Christian Klomp 2015-08-13 06:18:06 EDT
Created attachment 1062439 [details]
back trace 2
Comment 3 Christian Klomp 2015-08-13 06:18:32 EDT
Created attachment 1062441 [details]
back trace 3
Comment 4 Christian Klomp 2015-08-13 06:19:05 EDT
Created attachment 1062442 [details]
back trace 4
Comment 5 Christian Klomp 2015-08-13 06:19:35 EDT
Created attachment 1062443 [details]
back trace 5
Comment 6 Christian Klomp 2015-08-13 06:20:12 EDT
Created attachment 1062444 [details]
installed packages
Comment 7 Christian Klomp 2015-08-14 12:55:28 EDT
I've browsed a couple of hours on a Sandy Bridge IGP (instead the AMD Bulldozer system with a GTX 650 that was used for the back traces) and haven't had a single crash.

I've read that the crashes are supposedly caused by OMTC which I could have had enabled in FF39 myself which explains the pre FF40 crashes.
Besides the crashes with nouveau I'm fairly sure it also happened with the Nvidia proprietary driver (but I do not use that as often as nouveau so it could have been something else).

The work around of disabling OMTC seems to work and I've now been running a day without a problem (on the AMD Bulldozer system ).
I also tried to only disable the layers acceleration but that didn't work nor did the full disabling of hardware acceleration.

Since the work around seems to work I'll close this report.

Note You need to log in before you can comment on or make changes to this bug.