Bug 1253246 - virt-who can find the new guest, but can't update it to server at the same time.
virt-who can find the new guest, but can't update it to server at the same time.
Status: CLOSED DUPLICATE of bug 1246374
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Novacek
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 06:21 EDT by Eko
Modified: 2016-11-30 19:34 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-who-0.14-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 13:11:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eko 2015-08-13 06:21:41 EDT
Description of problem:
when adding or delete a guest, from the rhsm.log, virt-who can get the latest guest list immediately, but can't send the list to server at the same time.

Version-Release number of selected component (if applicable):
 - RHEL7.2-20150806.1-Server-x86_64(KVM) against stage candlepin
 - virt-who-0.14-3.el7.noarch
 - subscription-manager-1.15.9-2.el7.x86_64
 - python-rhsm-1.15.4-2.el7.x86_64

How reproducible:


Steps to Reproduce:
1. set VIRTWHO_INTERVAL=3

2. restart virt-who service

3. add a guest (rhel7.0-clone-test), check the rhsm.log, you can see the new guest "rhel7.0-clone-test" is already found, but can't find it from the "Sending domain info" list.

2015-08-13 17:59:25,292 [DEBUG]  @libvirtd.py:210 - Virtual machine found: rhel7.0: 95572a0b-390a-4364-ae96-a48c5134d47d
2015-08-13 17:59:25,293 [DEBUG]  @libvirtd.py:216 - Virtual machine found: rhel7.0-backup: 5262e779-29c6-4331-a344-c46e78012425
2015-08-13 17:59:25,293 [DEBUG]  @libvirtd.py:216 - Virtual machine found: rhel7.0-clone-test: 04d4c7ba-4fd3-432c-b59a-91e72e7edff8
2015-08-13 17:59:25,293 [DEBUG]  @libvirtd.py:220 - Libvirt domains found: ['95572a0b-390a-4364-ae96-a48c5134d47d', '5262e779-29c6-4331-a344-c46e78012425', '04d4c7ba-4fd3-432c-b59a-91e72e7edff8']
2015-08-13 17:59:25,493 [INFO]  @subscriptionmanager.py:136 - Sending domain info: [
    {
        "guestId": "5262e779-29c6-4331-a344-c46e78012425", 
        "state": 5, 
        "attributes": {
            "active": 0, 
            "virtWhoType": "libvirt", 
            "hypervisorType": "QEMU"
        }
    }, 
    {
        "guestId": "95572a0b-390a-4364-ae96-a48c5134d47d", 
        "state": 1, 
        "attributes": {
            "active": 1, 
            "virtWhoType": "libvirt", 
            "hypervisorType": "QEMU"
        }
    }
]
2015-08-13 17:59:30,209 [INFO]  @virtwho.py:190 - virt-who guest list update successful
2015-08-13 17:59:30,211 [DEBUG]  @subscriptionmanager.py:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem



Actual results:
virt-who can find the new guest, but will send it to the server next and next time. 
 
Expected results:
if virt-who can list the new guest, the guest uuid should be sent to the server at the same time.

Additional info:
Comment 2 Liushihui 2015-08-14 02:27:32 EDT
It seems the same problem of bug 1246374
Comment 3 Radek Novacek 2015-08-25 13:11:13 EDT
Yes, it's duplicate of 1246374.

*** This bug has been marked as a duplicate of bug 1246374 ***

Note You need to log in before you can comment on or make changes to this bug.