Bug 1253337 - kubectl should be in its own subpackage
kubectl should be in its own subpackage
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kubernetes (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
Chris Evich
: Extras
Depends On: 1241469
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 09:52 EDT by Stef Walter
Modified: 2015-09-15 08:52 EDT (History)
12 users (show)

See Also:
Fixed In Version: kubernetes-1.1.0-0.10.git280b66c.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1241469
Environment:
Last Closed: 2015-09-15 08:52:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2015-08-13 09:52:53 EDT
+++ This bug was initially created as a clone of Bug #1241469 +++

The kubectl command should be in its own subpackage. kubectl can be used on systems where neither a kubernetes-master or kubernetes-node should be installed. In addition it can be used against openshift/origin/atomic

Cockpit would like to depend on kubectl

<snip> ... fixed in Fedora, but not yet in RHEL:

--- Additional comment from Fedora Update System on 2015-07-31 03:54:41 EDT ---

kubernetes-1.0.0-0.9.git2d88675.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Jan Chaloupka 2015-08-13 10:13:08 EDT
Hi Stef,

planned for 7.1.5.
Comment 6 errata-xmlrpc 2015-09-15 08:52:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1776.html

Note You need to log in before you can comment on or make changes to this bug.