Bug 125339 - missing initrd entries in grub.conf
missing initrd entries in grub.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 16:55 EDT by John S. Monaco
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 17:24:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John S. Monaco 2004-06-04 16:55:41 EDT
Description of problem:
After a fresh build with latest development distribution, as of
06/04/2004, there is not an initrd entry in the grub.conf, such as:

initrd /initrd-2.6.6-1.414.img

Also, it looks like the initrd-2.6.6-1.414.img wasn't put in /boot either.

Version-Release number of selected component (if applicable):

anaconda-10.0.1-0.20040604015457.i386.rpm

How reproducible:
very

Steps to Reproduce:

1. Build fresh install
2. reboot
3. cat /grub/grub.conf within the grub shell
  
Actual results:

title Fedora Core (2.6.6-1.414)
        root (hd0,0)
        kernel /vmlinuz-2.6.6-1.414 ro root=/dev/sda2 rhgb quiet

Expected results:

title Fedora Core (2.6.6-1.414)
        root (hd0,0)
        kernel /vmlinuz-2.6.6-1.414 ro root=/dev/sda2 rhgb quiet
        initrd /initrd-2.6.6-1.414.img

Additional info:
Comment 1 Jeremy Katz 2004-06-04 17:24:30 EDT
The 414 kernel broke mlock which broke creating initrds.  Will be
fixed with newer kernels.

Note You need to log in before you can comment on or make changes to this bug.