Bug 1253443 - ipa vault-add creates vault with invalid type
ipa vault-add creates vault with invalid type
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 13:15 EDT by Scott Poore
Modified: 2015-11-19 07:05 EST (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2015-08-13 13:15:10 EDT
Description of problem:

[root@master ~]# ipa vault-add vname --type=type_dne
ipa: ERROR: invalid 'vault_type': Invalid vault type

[root@master ~]# ipa vault-find
---------------
1 vault matched
---------------
  Vault name: vname
  Type: type_dne
----------------------------
Number of entries returned 1
----------------------------

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.  ipa-server-install
2.  ipa-kra-install
3.  kinit admin
4.  ipa vault-add vname --type=type_dne


Actual results:
error message displayed but, adds vault even though the type is invalid

Expected results:
does not add vault

Additional info:
Comment 2 Scott Poore 2015-08-13 20:25:24 EDT
vault-mod does the same:

[root@master ~]# ipa vault-mod vault_test1 --type=invalid
----------------------------
Modified vault "vault_test1"
----------------------------
  Vault name: vault_test1
  Type: invalid
  Owner users: admin
Comment 3 Petr Vobornik 2015-08-14 03:02:31 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5211
Comment 6 Scott Poore 2015-08-21 13:58:14 EDT
Verified.

Version ::

ipa-server-4.2.0-5.el7.x86_64

Results ::

[root@master ~]# ipa vault-add vname --type=type_dne
ipa: ERROR: invalid 'type': must be one of 'standard', 'symmetric', 'asymmetric'

[root@master ~]# ipa vault-mod vault1 --type=invalid
ipa: ERROR: invalid 'type': must be one of 'standard', 'symmetric', 'asymmetric'
Comment 7 errata-xmlrpc 2015-11-19 07:05:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.