Bug 1253449 - rhel-osp-director: failing to update the stack with "openstack overcloud update stack --templates -e <yaml file> -i overcloud"
rhel-osp-director: failing to update the stack with "openstack overcloud upd...
Status: CLOSED DUPLICATE of bug 1252509
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: z1
: Director
Assigned To: chris alfonso
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 13:22 EDT by Alexander Chuzhoy
Modified: 2016-04-18 03:01 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 10:08:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-08-13 13:22:47 EDT
rhel-osp-director: failing to update the stack with  "openstack overcloud update stack   --templates -e <yaml file>   -i overcloud"


Environment:
instack-undercloud-2.1.2-23.el7ost.noarch


Steps to reproduce:
1. Deploy overcloud.
2. Subscribe all hosts in the overcloud with subscription manager and add them to some pool. Verify that yum repos are available and that running "yum update" actually works (don't actually update).
3. Run  "openstack overcloud update stack  --templates -e <yaml file>  -i overcloud"

Result:    
starting package update on stack overcloud 
IN_PROGRESS                                                                     
IN_PROGRESS                                                                     
IN_PROGRESS                                                                     IN_PROGRESS                                                                     
WAITING                                                                         
not_started: [u'overcloud-compute-0', u'overcloud-controller-0']
on_breakpoint: [u'overcloud-cephstorage-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode:                                  
removing breakpoint on overcloud-cephstorage-0                   
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
IN_PROGRESS                                          
WAITING                                              
completed: [u'overcloud-cephstorage-0']
on_breakpoint: [u'overcloud-compute-0', u'overcloud-controller-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode: 

removing breakpoint on overcloud-controller-0 IN_PROGRESS                                                                     IN_PROGRESS                                                                     IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
^[[CIN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
WAITING
completed: [u'overcloud-controller-0', u'overcloud-cephstorage-0']
on_breakpoint: [u'overcloud-compute-0']
Breakpoint reached, continue? Regexp or Enter=proceed, no=cancel update, C-c=quit interactive mode:
ERROR: openstack unexpected end of regular expression


Expected result:
The update should complete successfully.
Comment 3 Alexander Chuzhoy 2015-08-13 13:25:33 EDT
The bug didn't reproduce when I tried to run it on 2 different setups:
1)   1 Controller, 1 Ceph, 1 compute

2)   3 controller, 3 Ceph nodes, 1 compute.



Once reproduces, need to upload the output from "heat deployment-show
<depl_id>" where depl_id can be found by running "heat resource-list overcloud
-n 5|grep FAILED|grep UpdateDepl"
Comment 4 Zane Bitter 2015-08-14 04:29:31 EDT
Sasha, is that the output you intended to paste? It looks like you copied the one from bug 1252509 by accident. From your previous email I think the one you intended to paste went like this:


[stack@rhos-compute-node-13 ~]$ openstack overcloud update stack --templates   -i overcloud
starting package update on stack overcloud
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
FAILED
update finished with status FAILED

[stack@rhos-compute-node-13 ~]$ openstack overcloud update stack --templates  -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /home/stack/network-environment.yaml -i overcloud
starting package update on stack overcloud
IN_PROGRESS
IN_PROGRESS
IN_PROGRESS
FAILED
update finished with status FAILED

Looking closely at that, the first command omits the storage-environment and network-environment environment files that are included in the second one. Assuming that the stack was initially deployed with those environments (was it?) then it's expected that the stack will fail and be stuck in a failed state. That would explain why you can't reproduce it, if you're now passing the correct environment files.

If you confirm that the overcloud was initially deployed with the extra environment files then we can close this bug.
Comment 5 Alexander Chuzhoy 2015-08-14 09:12:23 EDT
This bug is a duplicate of #1252509.

The second failure in comment #4 is because I selected not to continue with the update.

On of the bugs can be closed as duplicate.
Comment 6 Zane Bitter 2015-08-14 10:08:07 EDT

*** This bug has been marked as a duplicate of bug 1252509 ***

Note You need to log in before you can comment on or make changes to this bug.