This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253455 - ipa vault-add creates vault when public-key-file does not exist
ipa vault-add creates vault when public-key-file does not exist
Status: CLOSED DUPLICATE of bug 1251561
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 13:41 EDT by Scott Poore
Modified: 2015-09-01 10:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 10:06:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2015-08-13 13:41:23 EDT
Description of problem:

[root@master ~]# ipa vault-add vname --public-key-file=/tmp/pwfile_dne
-------------------
Added vault "vname"
-------------------
  Vault name: vname
  Type: standard
  Owner users: admin

[root@master ~]# ipa vault-find
---------------
1 vault matched
---------------
  Vault name: vname
  Type: standard
----------------------------
Number of entries returned 1
----------------------------


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.  ipa-server-install
2.  ipa-kra-install
3.  kinit admin
4.  ipa vault-add vname --public-key-file=/tmp/pwfile_dne



Actual results:
creates vault

Expected results:
fails and does not create vault

Additional info:
Comment 2 Scott Poore 2015-08-13 21:13:54 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5217
Comment 3 Petr Vobornik 2015-08-24 12:57:37 EDT
Fixed by bug 1251561 (ipa-4.2.0-5.el7). See https://fedorahosted.org/freeipa/ticket/5195#comment:5

#  ipa vault-add vname --public-key-file=/tmp/pwfile_dne
ipa: ERROR: Public key can be specified only for asymmetric vault
Comment 4 Petr Vobornik 2015-09-01 10:06:04 EDT

*** This bug has been marked as a duplicate of bug 1251561 ***

Note You need to log in before you can comment on or make changes to this bug.