Bug 1253492 - caps lock/shift activates RaNdOmLy
caps lock/shift activates RaNdOmLy
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: screen (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Hracek
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 16:21 EDT by Rich Megginson
Modified: 2015-08-13 18:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-13 18:22:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2015-08-13 16:21:26 EDT
Description of problem:
I'm running RHEL7.2 (nightly candidate) in a VM and running the latest screen available for RHEL7.2.  At some point after using the Caps Lock key, screen loses track of the shift state, or perhaps the caps lock key is triggered randomly?  Because my TYPE appEARs liKE tHIs which maKEs tYPING PAsswordS almost impossible, among other annoyances.

Version-Release number of selected component (if applicable):
screen-4.1.0-0.19.20120314git3c2946.el7.x86_64

How reproducible:
randomly after using Caps Lock at least once

Steps to Reproduce:
1. Use the keyboard a lot - run vi, use Ctrl-A Esc copy mode to copy/paste text many times
2. Use the Caps Lock key a few times
3. Keep typing

At some point you will bEGIN to SEE that THE shift key IS acTIVATED ranDOMly

Actual results:


Expected results:


Additional info:
Comment 2 Rich Megginson 2015-08-13 18:22:36 EDT
sorry for the noise - may be a virsh vnc console display problem

Note You need to log in before you can comment on or make changes to this bug.