Bug 1253511 - ipa vault-find does not use criteria
ipa vault-find does not use criteria
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-13 18:19 EDT by Scott Poore
Modified: 2015-11-19 07:05 EST (History)
3 users (show)

See Also:
Fixed In Version: ipa-4.2.0-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:05:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2015-08-13 18:19:32 EDT
Description of problem:

I'm unable to search for a vault by name without using the --name argument.

[root@master ~]# ipa vault-find
----------------
3 vaults matched
----------------
  Vault name: vnaem
  Type: standard

  Vault name: vname2
  Type: standard

  Vault name: vname3
  Type: standard
----------------------------
Number of entries returned 3
----------------------------
[root@master ~]# ipa vault-find vnaem
----------------
0 vaults matched
----------------
----------------------------
Number of entries returned 0
----------------------------


Version-Release number of selected component (if applicable):
ipa-server-4.2.0-4.el7.x86_64

How reproducible:
always


Steps to Reproduce:
1.  ipa-server-install
2.  ipa-kra-install
3.  kinit admin
4.  ipa vault-add vaultname
5.  ipa vault-find vaultname

Actual results:
nothing found

Expected results:
result found matching name more like other ipa find commands.

Additional info:
Comment 2 Scott Poore 2015-08-13 21:13:33 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5212
Comment 5 Scott Poore 2015-08-21 14:13:52 EDT
Verified.

Version ::

ipa-server-4.2.0-5.el7.x86_64

Results ::

[root@master ~]# ipa vault-find vname
---------------
1 vault matched
---------------
  Vault name: vname
  Type: standard
  Vault user: admin
----------------------------
Number of entries returned 1
----------------------------
Comment 6 errata-xmlrpc 2015-11-19 07:05:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.