This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253521 - [RFE] Provide templates in /usr/share/openshift/examples/ as tar, zip or RPM include.
[RFE] Provide templates in /usr/share/openshift/examples/ as tar, zip or RPM ...
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On:
Blocks: 1267746
  Show dependency treegraph
 
Reported: 2015-08-13 21:33 EDT by Kenjiro Nakayama
Modified: 2016-04-04 08:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-04 08:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenjiro Nakayama 2015-08-13 21:33:19 EDT
Description of problem:
===
- After update v3.0.0.x to v3.0.1.0, we still hit the issue bz1245032 [1].
- The reason is that update steps described in [2] doesn't update the templates in /usr/share/openshift/examples/.
- Nobody wants to re-run install scripts to update templates. We can update by replacing the files, if you provide the template as tar or zip.

Reproduce steps
===
1. Update to v3.0.0.x to v3.0.1.0 followed by [2]
2. Create new application with template in /usr/share/openshift/examples/

Actual results:
===
- We will hit same issue with [1].

Expect results:
===
- We update templates and won't hit the issue[1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1245032
[2] https://docs.openshift.com/enterprise/3.0/admin_guide/upgrades.html
Comment 2 Kenjiro Nakayama 2015-08-18 00:34:32 EDT
I filed this RFE to provide templates as tar or zip first. However I think we can consider that we could include them in RPM package.
Comment 3 Brenton Leanhardt 2015-08-18 08:16:59 EDT
Lowering the severity because this is not a release blocker.  It sounds like the xpaas templates may soon be released as a zip file.  Whatever solution is determined for the rest of the templates needs to take Atomic Host installs in to account.  RPMs cannot be installed there.
Comment 4 Kenjiro Nakayama 2015-08-18 08:27:20 EDT
> It sounds like the xpaas templates may soon be released as a zip file.

I heard about it more than 10 days ago, but the progress is unclear and no update.
Therefore, I filed this request to watch the progress. Please don't wait for the customer any longer...
Comment 5 Ryan Howe 2015-09-23 16:17:24 EDT
Have we released these templates yet in a zip file??
Comment 6 Scott Dodson 2015-09-23 16:35:43 EDT
Sort of, they're collated currently in openshift-ansible, so you can download that repo as a zip file and pull them from roles/openshift_examples/files/examples

https://codeload.github.com/openshift/openshift-ansible/zip/master

However, we'll likely move them from ansible into the openshift RPM as that will enable us to ensure that new content is delivered along with OpenShift releases. Right now they're really only updated if a user updates the installer or openshift-ansible and re-runs them, which rarely if ever happens.

This doesn't meet the needs of non-entitled or non-rhel hosts like a developer running MacOSX who wants to look at the templates. I think this bug should be split to address those two needs separately and each bug should be prioritized individually.
Comment 8 Kenjiro Nakayama 2016-03-29 11:42:49 EDT
This issue (RH doesn't provide template as zip or RPM) is not so severe, but inconvenient, since "/usr/share/openshift/examples" is made on only host on which ansible installer.

Also, we can't track their versions..
Comment 9 Kenjiro Nakayama 2016-04-04 01:11:13 EDT
OK, I realized that we provide the template in the package openshift-ansible-roles under 
/usr/share/ansible/openshift-ansible/roles/openshift_examples/files/examples/v1.1/*

Can we close this ticket?
Comment 10 Brenton Leanhardt 2016-04-04 08:26:48 EDT
Sure.  Definitely let us know if customer prefer another approach.

Note You need to log in before you can comment on or make changes to this bug.