Bug 1253552 - scl enable devtoolset-3 'eclipse' crashes
scl enable devtoolset-3 'eclipse' crashes
Status: CLOSED NOTABUG
Product: softwarecollections.org
Classification: Community
Component: Other (Show other bugs)
1.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Roland Grunberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 01:47 EDT by Kieran Shanley
Modified: 2016-05-03 09:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 09:32:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file referred to in error dialog (140.96 KB, text/plain)
2015-08-14 01:47 EDT, Kieran Shanley
no flags Details

  None (edit)
Description Kieran Shanley 2015-08-14 01:47:22 EDT
Created attachment 1062880 [details]
log file referred to in error dialog

Description of problem:
When you try and launch eclipse after a fresh install of devtoolset-3 it fails to launch and displays a dialog referencing a log file (/home/<user>/.eclipse/org.eclipse.platform_679667225_linux_gtk_x86_64/configuration/1439528607395.log). The log file contains many errors referring to:

Unresolved requirement: Require-Bundle: org.eclipse.emf.ecore; bundle-version="2.9.0"


Version-Release number of selected component (if applicable):
RHEL 6

How reproducible:

Very
Steps to Reproduce:
1. Install RHEL 6
2. add Devtoolset-3 and Common Java Packages 1.1 repos from software collections
3. install devtoolset-3
4. try and launch eclipse using "scl enable devtoolset-3 'eclipse'"

Actual results:

The following text is displayed on the console:

CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/eclipse/tycho/core/osgitools/EquinoxResolver.newState

(<unknown>:9076): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(<unknown>:9076): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `GDK_IS_PIXBUF (pixbuf)' failed

(<unknown>:9076): Gtk-CRITICAL **: IA__gtk_window_resize: assertion `width > 0' failed

A dialog showing the following text is displayed:

An error has occurred. See the log file
/home/<user>/.eclipse/org.eclipse.platform_679667225_linux_gtk_x86_64/configuration/1439528607395.log.


Expected results:

eclipse to launch and display workbench


Additional info:

I have tried removing existing .eclipse folders and workspaces and tried launching with -clean to no avail.
Comment 1 Roland Grunberg 2015-09-01 12:50:22 EDT
After investigating, it looks like the version of devtoolset-3-emf-core (devtoolset-3-eclipse-emf-core-2.10.2-2.el6.x86_64) in the software collection has '/opt/rh/devtoolset-3/root/usr/lib64/eclipse/plugins/org.eclipse.emf.ecore_2.10.2.v20150616-1700.jar' , but in the bundles.info file the plugin referenced is older :

$ grep org.eclipse.emf.ecore_ /opt/rh/devtoolset-3/root/usr/lib64/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
org.eclipse.emf.ecore,2.10.2.v20150407-0800,plugins/org.eclipse.emf.ecore_2.10.2.v20150407-0800.jar,4,false

This usually indicates that a newer version of emf was built, and eclipse was not rebuilt afterwards. I'd recommend doing a rebuild of the eclipse package in the collection so that it may use the newer version of emf.
Comment 2 Adam Samalik 2015-09-02 07:06:25 EDT
I have rebuilt the eclipse package and the error remains.
Comment 3 Marek Polacek 2015-09-02 07:30:04 EDT
This needs to be handled by the Eclipse team; this is not my area.
Comment 5 Roland Grunberg 2015-09-02 12:35:49 EDT
The rebuild worked for me but maybe you can try removing or backing up your "$HOME/.eclipse" folder, and then launching Eclipse again.
Comment 8 Alexander Kurtakov 2016-05-03 09:32:25 EDT
As there is no reply from submitter for more than half a year and DTS 4.0 is out since then - marking the bug as closed. If problem still exists with DTS 4.0 please open a new bug with details.

Note You need to log in before you can comment on or make changes to this bug.