Bug 1253566 - Broken boot
Broken boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1253968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 02:14 EDT by poma
Modified: 2015-09-22 16:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-21 15:17:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description poma 2015-08-14 02:14:55 EDT
Broken boot kernel 4.1.0-1.fc23 ... 4.2.0-0.rc6.git0.2.fc23.i686+PAE

4.2.0-0.rc6.git0.2.fc23.i686+PAE:
Call Trace:
  detect_cache_attributes+0x19e/0x2a0
  ? container_dev_init+0x28/0x28
  cacheinfo_sysfs_init+0x31/0x74
  do_one_initcall+0xaa/0x200
  ? container_dev_init+0x28/0x28
  ? repair_env_string+0x12/0x54
  ? kernel_init_freeable+0x123/0x1d1
  kernel_init_freeable+0x143/0x1d1
  kernel_init+0x10/0xe0
  ret_from_kernel_thread+0x21/0x30
  ? rest_init+0x70/0x70
...
---[ end trace ...


Similar case:
http://oi61.tinypic.com/16hojlx.jpg
https://bbs.archlinux.org/viewtopic.php?pid=1548360#p1548360

Ref.
https://bugzilla.kernel.org/show_bug.cgi?id=101971
Comment 1 poma 2015-08-14 06:24:22 EDT
kernel-4.1.5-200.fc22
&
kernel-4.2.0-0.rc6.git0.2.fc23

patched with:
0001-cpu-cacheinfo-Fix-teardown-path.patch
https://bugzilla.kernel.org/attachment.cgi?id=183881

Both kernels have PASSED.

Fedora 22, 23 and Rawhide' kernels - Ready Steady Go!
Comment 2 Josh Boyer 2015-08-16 08:28:11 EDT
*** Bug 1253968 has been marked as a duplicate of this bug. ***
Comment 3 Richard Jasmin 2015-08-17 11:44:48 EDT
Uh...you didnt post your changes to the repo if its been fixed. Just spun yesterday and 22 still has the borked kernel in it.
Comment 5 poma 2015-09-22 16:20:47 EDT
dmesg-t-4.1.8-200.fc22.i686+debug
dmesg-t-4.2.1-300.fc23.i686+debug
dmesg-t-4.3.0-0.rc2.git1.1.fc24.i686
ALL PASSED/BOOTABLE

Note You need to log in before you can comment on or make changes to this bug.