Bug 1253587 - fix permission of /usr/lib/systemd/system/rtcheck.service
fix permission of /usr/lib/systemd/system/rtcheck.service
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rtcheck (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: John Kacur
Jiri Kastner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 03:41 EDT by Jiri Kastner
Modified: 2015-11-19 08:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 08:22:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2015-08-14 03:41:47 EDT
Description of problem:
rtcheck.service has 755, while most of *.service files in /usr/lib/systemd/system/ have 644

Version-Release number of selected component (if applicable):
rtcheck-0.7.7-5.el7

How reproducible:


Steps to Reproduce:
1. install rtcheck
2. ll /usr/lib/systemd/system/rtcheck.service
3. check output

Actual results:
-rwxr-xr-x. 1 root root 447 Jul  6 18:25 /usr/lib/systemd/system/rtcheck.service


Expected results:
-rw-r--r--. 1 root root 447 Jul  6 18:25 /usr/lib/systemd/system/rtcheck.service


Additional info:
Comment 1 Jiri Kastner 2015-08-14 03:45:55 EDT
[root@mrg-qe-15 ~]# rpm -Va rtcheck
[root@mrg-qe-15 ~]# git apply --directory=/lib/systemd/system/ -R rtcheck.patch -p1
warning: /lib/systemd/system/rtcheck.service has type 100755, expected 100644
[root@mrg-qe-15 ~]# rpm -Va rtcheck
missing     /usr/lib/systemd/system/rtcheck.service
[root@mrg-qe-15 ~]# git apply --directory=/lib/systemd/system/ rtcheck.patch -p1
[root@mrg-qe-15 ~]# rpm -Va rtcheck
.M.....T.    /usr/lib/systemd/system/rtcheck.service
[root@mrg-qe-15 ~]# rpm -q rtcheck
rtcheck-0.7.7-5.el7.x86_64
Comment 3 John Kacur 2015-08-14 08:12:14 EDT
Fixed in rtcheck-0.7.7-6 and up
Comment 6 errata-xmlrpc 2015-11-19 08:22:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2410.html

Note You need to log in before you can comment on or make changes to this bug.