Bug 1253589 - Search works improperly for Docker(Hub) Container create procedure
Search works improperly for Docker(Hub) Container create procedure
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.1.0
x86_64 Linux
unspecified Severity high (vote)
: GA
: --
Assigned To: Daniel Lobato Garcia
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 03:59 EDT by Oleksandr Shtaier
Modified: 2016-04-22 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 04:33:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error messages example (84.14 KB, image/png)
2015-08-14 03:59 EDT, Oleksandr Shtaier
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14406 None None None 2016-04-22 12:32 EDT

  None (edit)
Description Oleksandr Shtaier 2015-08-14 03:59:47 EDT
Created attachment 1062916 [details]
Error messages example

Description of problem:
Getting different error messages while trying to input any string in 'search' field of Docker Hub tab in new 'New Container'->'Image' section
That issue is referring to docker daemon 1.6.2 version

Version-Release number of selected component (if applicable):
RC1

How reproducible:
Always

Steps to Reproduce:
1. Create new Docker compute resource
2. Create Product and add Docker repository to it. (e.g. 'busybox' from 'https://registry.hub.docker.com')
3. Sync that repo (In result we should have repo with some Docker Images and some Docker Tags inside)
4. Push 'New Container' button
5. Preliminary->Deploy on->Select Docker compute resource from step 1
6. Next->Image->Docker Hub
7. Input any existing container name to search field(e.g. 'centos')

Actual results:
Getting error message in UI:
NoMethodError
undefined method `info' for nil:NilClass
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call' 

Expected results:
Container found and necessary tag displayed in the 'Tag' field

Additional info:

That behaviour was mentioned in 1253270 bug, but definitely worth to create separate defect
Comment 3 Daniel Lobato Garcia 2016-03-31 02:35:02 EDT
Created redmine issue http://projects.theforeman.org/issues/14406 from this bug
Comment 4 Daniel Lobato Garcia 2016-04-04 03:16:33 EDT
Do you have a reproducer for this on the latest snap? Your steps indicate you understood the container creation process wrong:

In steps 2 and 3 you create a Product and sync, but on step 6 you decide to use the Docker hub. Why do you even sync the Product if you plan to use the hub image instead?
Comment 5 Oleksandr Shtaier 2016-04-06 04:32:55 EDT
1) Yes, you are right about the process. I just used same process for all docker related things. And yes, I have lack of experience in that area, but now I see correct flow. There is a slight chance that steps 2 and 3 can impact overal flow, but it is not a case here
2) Docker package is already upgraded bunch of times and we should not support all versions of that package
3) Functionality works as intended for last docker daemon and application version

Note You need to log in before you can comment on or make changes to this bug.