Bug 1253592 - RFE: targetd add support to access group operations
RFE: targetd add support to access group operations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetd (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: 7.4
Assigned To: Tony Asleson
Martin Hoyer
Milan Navratil
: FutureFeature
Depends On:
Blocks: 1385242
  Show dependency treegraph
 
Reported: 2015-08-14 04:12 EDT by Bruno Goncalves
Modified: 2017-08-01 16:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:43:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2015-08-14 04:12:02 EDT
Description of problem:
Current targetd on RHEL-7.2 does not allow access group operations. 

Libstoragemgmt supports targetd, but it is not possible to perform volume-mask nor volume-unmask, because targetd does not support it.

# lsmcli  -u "targetd://admin@localhost" access-group-create --name test --init iqn.1994-05.com.redhat:cbc17c91e2b --sys targetd
NO_SUPPORT(153): Please upgrade your targetd package to support access_group_create() 


Version-Release number of selected component (if applicable):
targetd-0.7.1-1.el7.noarch

Additional info:
Version 0.8.3 from Fedora supports it.

tested using targetd-0.8.3-1.fc22.noarch
Comment 5 Bruno Goncalves 2017-03-29 10:55:06 EDT
It looks good. Tested with:
targetd-0.8.5-1.el7.noarch
libstoragemgmt-targetd-plugin-1.4.0-2.el7.noarch

# lsmcli  -u "targetd://admin@localhost" access-group-create --name=lsm-igroup --init=iqn.1994-05.com.redhat:lsm-test-iqn --sys=targetd
ID         | Name       | Initiator IDs                       | System ID
-------------------------------------------------------------------------
lsm-igroup | lsm-igroup | iqn.1994-05.com.redhat:lsm-test-iqn | targetd
Comment 6 Bruno Goncalves 2017-04-28 10:35:07 EDT
Tony,

When we use the targetd plugin LIO is configured to use "0.0.0.0:3260" as port IP address, this do not allow IPv6 to discover the target. Is this okay? "0.0.0.0:3260" is what targetcli creates by default.

libstoragemgmt-1.4.0-3.el7
targetd-0.8.5-1.el7
targetcli-2.1.fb46-1.el7


# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................. [Storage Objects: 1]
  | | o- vg-targetd:lsm-lun-update .................................. [/dev/vg-targetd/lsm-lun-update (2.0GiB) write-thru activated]
  | |   o- alua ................................................................................................... [ALUA Groups: 1]
  | |     o- default_tg_pt_gp ....................................................................... [ALUA state: Active/optimized]
  | o- fileio ................................................................................................. [Storage Objects: 0]
  | o- pscsi .................................................................................................. [Storage Objects: 0]
  | o- ramdisk ................................................................................................ [Storage Objects: 0]
  o- iscsi ............................................................................................................ [Targets: 1]
  | o- iqn.2003-01.org.linux-iscsi.storageqe-72.lab.eng.brq.redhat.com:targetd ........................................... [TPGs: 1]
  |   o- tpg1 ............................................................................................... [no-gen-acls, no-auth]
  |     o- acls .......................................................................................................... [ACLs: 1]
  |     | o- lsm-igroup .................................................... [(iqn.1994-05.com.redhat:lsm-test-iqn), Mapped LUNs: 1]
  |     |   o- mapped_lun0 ............................................................. [lun0 block/vg-targetd:lsm-lun-update (rw)]
  |     o- luns .......................................................................................................... [LUNs: 1]
  |     | o- lun0 ............................ [block/vg-targetd:lsm-lun-update (/dev/vg-targetd/lsm-lun-update) (default_tg_pt_gp)]
  |     o- portals .................................................................................................... [Portals: 1]
  |       o- 0.0.0.0:3260 ..................................................................................................... [OK]
  o- loopback ......................................................................................................... [Targets: 0]
Comment 7 Tony Asleson 2017-04-28 12:50:54 EDT
(In reply to Bruno Goncalves from comment #6)
> Tony,
> 
> When we use the targetd plugin LIO is configured to use "0.0.0.0:3260" as
> port IP address, this do not allow IPv6 to discover the target. Is this
> okay? "0.0.0.0:3260" is what targetcli creates by default.

Please write up an enhancement BZ for ipv6 support.
Comment 10 Martin Hoyer 2017-05-29 06:15:55 EDT
Tested with targetd-0.8.5-1.el7
Access group operations works. No regression found.
Comment 11 errata-xmlrpc 2017-08-01 16:43:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1982

Note You need to log in before you can comment on or make changes to this bug.