Bug 1253596 - [RFE]- OpenShift SDN does not have configuration options for the self IP (https://github.com/openshift/openshift-sdn/issues/84)
[RFE]- OpenShift SDN does not have configuration options for the self IP (htt...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rajat Chopra
Meng Bo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 04:21 EDT by Miheer Salunke
Modified: 2015-09-22 15:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: openshift-3.0.1.900-0.git.251.56c53fd.el7ose.x86_64
Doc Type: Enhancement
Doc Text:
Feature: Admins may now configure the IP address used for SDN traffic. Reason: Admins may wish to use a certain network interface for SDN traffic or reconfigure the IP address used for SDN traffic. Result: Admins may now configure the IP address used for SDN traffic.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 15:52:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miheer Salunke 2015-08-14 04:21:51 EDT
1. Proposed title of this feature request  
    => 	OpenShift SDN does not have configuration options for the self IP

     https://github.com/openshift/openshift-sdn/issues/84 
      


2. What is the nature and description of the request?  
    => When there are multiple IPs for a hostname the value can be incorrect.
       There should be a config value for the node and for the master for the   IP for SDN to bind to.

      
3. Is there already an existing RFE upstream or in Red Hat Bugzilla? 
=>    Yes.   https://github.com/openshift/openshift-sdn/issues/84
    
    
4. List any affected packages or components.  
=> Openshift SDN
Comment 5 Scott Dodson 2015-09-10 12:57:04 EDT
Docs on how to configure this 
https://github.com/openshift/openshift-docs/issues/937
Comment 7 Meng Bo 2015-09-11 06:32:08 EDT
The node IP can be configured in node-config.yaml now which will resolve this issue.

Move bug to verified.
Comment 11 errata-xmlrpc 2015-09-22 15:52:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1835

Note You need to log in before you can comment on or make changes to this bug.