Bug 1253597 - [GSS](6.4.x) Exceptions of lifecycle methods for session beans are suppresses without any message
[GSS](6.4.x) Exceptions of lifecycle methods for session beans are suppresses...
Status: CLOSED DUPLICATE of bug 1207240
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld, EJB (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: wfink
Matous Jobanek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 04:23 EDT by wfink
Modified: 2015-08-14 04:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 04:34:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2281 Major Resolved Exception from lifecycle callback interceptor method intercepting a session bean gets suppressed without log message 2015-08-14 04:35:06 EDT

  None (edit)
Description wfink 2015-08-14 04:23:58 EDT
Description of problem:
If a lifecycle method of EJB's throw an Exception it is expected that this will be logged and the invocation fail.
This works correct if there is no CDI involved in this deployment.
If a beans.xml is added the Exception is swallowed and the instance might work not correct.



How reproducible:
----- Class ----
@Singleton
@Startup
public class StartupSingletonBean {
  private static final Logger log = Logger.getLogger(StartupSingletonBean.class);

  @PostConstruct
  private void postConstruct() {
    log.info("StartupSingleton is started. Resource 'myString' is '" + myString + "'");
    throw new RuntimeException("THIS IS A TEST");
  }
}



Steps to Reproduce:
1. If the application does not contain a beans.xml the Exception is logged and the Bean is not created.
2. If the application contains a beans.xml the weld deployment is activated and the Exception is swallowed.
Comment 1 wfink 2015-08-14 04:34:59 EDT

*** This bug has been marked as a duplicate of bug 1207240 ***

Note You need to log in before you can comment on or make changes to this bug.