Bug 125362 - python-doc html files have japanese character encoding
python-doc html files have japanese character encoding
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-04 22:55 EDT by Todd Valentic
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.4-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 13:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Valentic 2004-06-04 22:55:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Quite a few of the python documentation HTML pages specify the charset
"EUC-JP", causing Mozilla to display them in an odd font. For example,
the file:

    /usr/share/doc/python-docs-2.3.3/html/lib/module-os.html

has the following line in the header porition:

   <meta http-equiv="Content-Type" content="text/html; charset=EUC-JP">

The top level documentation files are not affected. For example, 

   /usr/share/doc/python-docs-2.3.3/html/modindex.html

uses the following encoding:

   <meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1">

and displays normally.

Version-Release number of selected component (if applicable):
python-docs-2.3.3-6

How reproducible:
Always

Steps to Reproduce:
1. Make sure the python-docs rpm is installed
2. Start mozilla
3. Open file:///usr/share/doc/python-docs-2.3.3/html/lib/module-os.html
    

Actual Results:  The page loaded with an odd looking, non standard
font corresponding to the japanese character encoding. If you change
the character encoding to ISO-8859-1 (western) via the View->Character
Encoding menu, the page is rendered in the standard font.

Expected Results:  The pages should be rendered in the ISO-8859-1
character set and appear the same as other pages.

Additional info:
Comment 1 Mihai Ibanescu 2004-06-17 12:13:10 EDT
I tried to figure out why, but no progress. I'll keep chasing it.
Comment 2 David Fraser 2004-06-18 04:57:54 EDT
Note that the standard docs on the python web page don't have this
problem... the following command can be used to quickly resolve this
(though obviously the rpms should be fixed)
cd /usr/share/python-docs-2.3.3/html
grep -irl 'charset=EUC-JP' . | xargs sed -i
's/charset=EUC-JP/charset=iso-8859-1/'
Comment 3 Mihai Ibanescu 2004-06-18 08:19:42 EDT
Yeah, I have to identify why it happens though...
Comment 4 Todd Valentic 2004-06-18 10:15:31 EDT
Here's one place to check - the latex2html conf file. Since the
documents are generated using latex2html, I took a look at the
configuration file shipped as default with FC2
(/usr/share/latex2html/l2hconf.pm). If you grep for the line with
"$default_language", you'll see that english is
commented out and japanese is set. Looking at the same file on one of
my FC1 machices shows that it used to default to english. 

This parameter causes the corresponding file in styles to be used.
Looking at styles/japanese.perl, the charset to be definted as "EUC-JP".
Comment 5 Mihai Ibanescu 2004-08-03 08:30:02 EDT
Seems to be fixed in 2.3.4-7, can you please confirm?
Comment 6 John Thacker 2006-04-21 13:09:25 EDT
This is fixed.  Closing.

Note You need to log in before you can comment on or make changes to this bug.