Bug 125363 - Speex support broken in gnomemeeting
Speex support broken in gnomemeeting
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnomemeeting (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-05 00:06 EDT by Jean-Marc Valin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 11:17:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Marc Valin 2004-06-05 00:06:56 EDT
Description of problem:
When using Speex as the codec for gnomemeeting, only noise is heard.
All other codecs work fine.

Version-Release number of selected component (if applicable):
1.0

How reproducible:
Always reproducible

Steps to Reproduce:
1. Start gnomemeeting with Speex as the default codec (on both sides)
2. Connect to other client
3.
  
Actual results:
Loud noise is heard instead of voice. Setting up any other codec works
fine.

Expected results:
Clear voice.

Additional info:
I'm the Speex author. I strongly suspect that the problem is in the
packaging of either openh323 or gnomemeeting. With running FC1 with
gnomemeeting 1.0 (installed from RPMs on the gnomemeeting site),
everything is fine. Both FC1 and FC2 use Speex 1.0.3 which is pretty
stable and I even tried replacing it with a version of libspeex which
I know works.
Comment 1 Daniel Reed 2004-10-08 23:03:33 EDT
I have limited ability to test gnomemeeting's various features and
modes; can you suggest anything specific in openh323/gnomemeeting's
packaging for me to investigate, or should I migrate this bug
upstream? Thanks.
Comment 2 Jean-Marc Valin 2004-10-14 05:39:59 EDT
Anytime I try communicating with another machine using Speex (making
both parties default to it) failed (heard only noise). It seems like
Speex support is completely broken (it's not just a special case that
fails), at least in my case.
Comment 3 Daniel Reed 2004-10-14 11:17:01 EDT
Migrated to: http://bugzilla.gnome.org/show_bug.cgi?id=155399

Note You need to log in before you can comment on or make changes to this bug.