Bug 1253644 - CFME doesn't receive events from RHOS 7(RabbitMQ)
CFME doesn't receive events from RHOS 7(RabbitMQ)
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.0
Assigned To: Greg Blomquist
Dave Johnson
: ZStream
Depends On:
Blocks: 1262014
  Show dependency treegraph
 
Reported: 2015-08-14 07:19 EDT by Nandini Chandra
Modified: 2015-11-11 15:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1262014 (view as bug list)
Environment:
Last Closed: 2015-09-10 14:57:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-08-14 07:19:01 EDT
Description of problem:
-----------------------
CFME is not receiving events from a RHOS 7 Beta set up.

I found this error in /var/log/rabbitmq/<.log> on the RHOS 7 Management node.

=INFO REPORT==== 13-Aug-2015::08:07:31 ===
accepting AMQP connection <0.14514.537> (xx.yy.zz.ww:41184 -> aa.bb.cc.dd:5672)

=ERROR REPORT==== 13-Aug-2015::08:07:31 ===
closing AMQP connection <0.14514.537> (xx.yy.zz.ww:41184 -> aa.bb.cc.dd:5672):
{bad_version,{1,1,0,10}}

I believe the {1,1,0,10} tuple refers to AMQP 0.10 and RabbitMQ primarily uses AMQP 0-9-1.

aa.bb.cc.dd is the RHOS Management node.
xx.yy.zz.ww is a CFME appliance


Version-Release number of selected component (if applicable):
------------------------
5.4.1


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Add a RHOS 7 provider to CFME.


Actual results:
---------------
CFME 5.4 appliance uses wrong client and doesn't receive events from RHOS 7.


Expected results:
----------------
CFME should receive events from RHOS 7.


Additional info:
----------------
Comment 5 Nandini Chandra 2015-09-02 16:58:15 EDT
Tested RHOS 7 GA and CFME can't receive events from RHOS 7 GA.
Comment 6 Nandini Chandra 2015-09-02 17:00:26 EDT
Snippet from /var/log/rabbitmq/<.log> 

=ERROR REPORT==== 2-Sep-2015::15:10:12 ===
closing AMQP connection <0.21830.0> (xx.yy.zz.11:47048 ->aa.bb.cc.11:5672):
{bad_version,{1,1,0,10}}

=INFO REPORT==== 2-Sep-2015::15:10:12 ===
accepting AMQP connection <0.21833.0> (xx.yy.zz.11:47049 -> aa.bb.cc.11:5672)

=INFO REPORT==== 2-Sep-2015::15:10:12 ===
closing AMQP connection <0.21833.0> (xx:yy.zz.11:47049 -> aa.bb.cc.11:5672)

=INFO REPORT==== 2-Sep-2015::15:10:12 ===
Comment 9 Greg Blomquist 2015-09-10 09:30:13 EDT
Nandini, can you retest this with the OSP7 environment?

From all the email conversations back and forth:

This is happening because of https://bugzilla.redhat.com/show_bug.cgi?id=1212158

I don't know the timeline for the OSP development team to fix and release that.  So, in the meantime, this is a manual fix in the OSP environment.

Pete Savage updated the OSP7 environment already.  So, this should be retested there to make sure it's working correctly.
Comment 10 Nandini Chandra 2015-09-10 14:57:58 EDT
I have retested with the OSP7 env and it's working correctly after the OSP7 env was updated.

Closing this bug since this is a RHOS bug.

Note You need to log in before you can comment on or make changes to this bug.