This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253646 - needinfo flagged bugs do no longer have "needinfo" status
needinfo flagged bugs do no longer have "needinfo" status
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 07:25 EDT by Germano Massullo
Modified: 2015-08-16 19:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-16 19:57:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2015-08-14 07:25:37 EDT
Description of problem:
In your buglist and in bug view like https://bugzilla.redhat.com/show_bug.cgi?id=1224988, if a bugreport is marked as "needinfo", the status instead is not marked as needinfo. Something broken in recent bugzilla versions, because usually when a bug was marked as needinfo, also the status reflected the "needinfo" flag.

Additional info:

I attach the outstanding request e-mail I receive every 7 days from bugzilla, so you can check some bugs that are marked as needinfo but their status instead is simply "new"

==========================
The following is a list of bugs or attachments to bugs in which a user has been
waiting more than 7 days for a response from you. Please take
action on these requests as quickly as possible. (Note that some of these bugs
might already be closed, but a user is still waiting for your response.)

We'll remind you again in another 7 days if these requests are still
outstanding, or if there are any new requests where users have been waiting
more than 7 days for your response.

needinfo
--------

  Bug 1224988: CUPS returns "filter failed" while printing PDF files (55 days old)
    https://bugzilla.redhat.com/show_bug.cgi?id=1224988
  
  Bug 1246433: Recent updates have broken two fingers scroll support for touchpad (14 days old)
    https://bugzilla.redhat.com/show_bug.cgi?id=1246433
==========================
Comment 1 Jason McDonald 2015-08-16 19:57:32 EDT
Needinfo is not a status in Red Hat Bugzilla -- it's a flag.

This is not a recent change: needinfo has been a flag rather than a status since around 2007.  In my opinion, as a long time administrator of bug-tracking systems, this is correct behaviour.  Requesting information is a valid thing to do in any bug state (even CLOSED) and therefore should not disrupt the regular bug lifecycle, nor oblige the user providing the info to also figure out how to send the bug back to the right state and assignee afterwards.  Further, the needinfo flag can be targeted at multiple users.

Taking Bug 1224988 as an example, the bug status is currently NEW because nobody has started working on a solution yet.  The needinfo flag is set for that bug (you can see it if you scroll down to the Flags section at the bottom of the right-hand column) and the title of the bug also has "NEEDINFO" next to it to highlight that information is required.

Finally, when looking at bug_list.cgi you can see which bugs have needinfo set by clicking the Change Columns link at the foot of the page and adding the Flags column to the list.

Note You need to log in before you can comment on or make changes to this bug.