Bug 1253657 - Not possible to use more different schemas
Not possible to use more different schemas
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-extension-aaa-jdbc (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.6.0
Assigned To: Martin Perina
Ondra Machacek
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 07:54 EDT by Ondra Machacek
Modified: 2016-02-10 14:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:53:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44994 master MERGED core: Set custom schema as default using custom DataSource Never

  None (edit)
Description Ondra Machacek 2015-08-14 07:54:28 EDT
Description of problem:
Since schema is static varibale, it's not possible to use more different values 
for it. The last one wins, and it's not possible to use other profiles, which use
different schema name.

Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-jdbc-0.0.0-4.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. Create two profiles, each with diffrent schema name
2. restart engine
3. Check which profile was loaded as first one
4. try to login to this profile

Actual results:
Fail to login.


Expected results:
Succed to login.

Additional info:
2015-08-14 12:51:09,204 TRACE [org.ovirt.engine.extension.aaa.jdbc.core.datasource.Sql] (ajp-/127.0.0.1:8702-2) [] cursor for: SELECT uuid, name, value, description FROM public.settings;

2015-08-14 12:51:09,208 DEBUG [org.ovirt.engine.extension.aaa.jdbc.binding.api.AuthnExtension] (ajp-/127.0.0.1:8702-2) [] Exception:: org.postgresql.util.PSQLException: ERROR: relation "public.settings" does not exist
  Position: 44


It always uses the schema name of profile, which is loaded as last one.
Comment 1 Martin Perina 2015-08-21 21:54:09 EDT
Fix included in ovirt-engine-extension-aaa-jdbc-0.0.0-5.el6ev
Comment 2 Ondra Machacek 2015-09-10 07:19:42 EDT
works fine with ovirt-engine-extension-aaa-jdbc-0.0.0-6.el6ev.noarch
Comment 3 Sandro Bonazzola 2015-11-04 08:53:04 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.