Bug 1253673 - Satellite Upgrade fails with error 'Upgrade step errata_import failed. Check logs for more information.'
Satellite Upgrade fails with error 'Upgrade step errata_import failed. Check ...
Status: CLOSED DUPLICATE of bug 1213000
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 08:27 EDT by Jitendra Yejare
Modified: 2017-02-23 14:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-14 11:21:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors and Misbehaving in Upgrade (28.18 KB, text/plain)
2015-08-14 08:27 EDT, Jitendra Yejare
no flags Details
Satellite Foreman-Debug (788.68 KB, application/x-xz)
2015-08-14 08:28 EDT, Jitendra Yejare
no flags Details

  None (edit)
Description Jitendra Yejare 2015-08-14 08:27:42 EDT
Created attachment 1063006 [details]
Errors and Misbehaving in Upgrade

Description of problem:
Satellite upgrade from Satellite 6.0.8 to Satellite 6.1.1 Snap 16 failed with error 'Upgrade step errata_import failed. Check logs for more information.'

Version-Release number of selected component (if applicable):
Satellite 6.1.1 snap 16 latest.

How reproducible:

Pre-condition:
Satellite 6.0.8 with at least one capsule associated with it. And the capsule is synced.

Steps to Reproduce:
On satellite 6.0.8, do this before upgrading,
1. Clone the CV used for associating capsule.
2. Then publish and promote the cloned CV.
3. Create new Activation Key with this cloned CV.

4. Create a sync plan with daily interval and start from current date and time.

5. Go to Host group, Create one Host Group.
6. Clone this host group.

7. Create a custom product with latest snap baseurl capsule repo to perform capsule upgrade later.

8. Now start the upgrade process.

Actual results:
Satellite upgrade failed with below outputs:
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_mongo...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..........................................................................................................................................................]
  The full log is at /var/log/katello-installer/katello-installer.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: errata_import (this may take a while) ...
Upgrade step errata_import failed. Check logs for more information.


Expected results:
Satellite Upgrade success.

Additional info:
I can see lot of error logs in foreman/production.log and katello-installer.log, when running katello-installer --upgrade on satellite.

Please find attached snapshot of errors and misbehaving logs while upgrade in process.
Also the foreman-debug.
Comment 1 Jitendra Yejare 2015-08-14 08:28:56 EDT
Created attachment 1063007 [details]
Satellite Foreman-Debug
Comment 2 Jitendra Yejare 2015-08-14 08:31:41 EDT
After Satellite finished with this issue, I tried to browse the satellite and It was accessible and it displays Sat 6.1.1 version.
But the two host groups that I created and one of it was cloned from another. Accessing those Host Groups it throws an error of :

'''
Oops, we're sorry but something went wrong
 
undefined method `use_puppet_default' for #<LookupValue:0x0000000f72df08>

If you feel this is an error with Satellite 6 itself, please open a new issue with Satellite ticketing system, You would probably need to attach the Full trace and relevant log entries. 
'''
Comment 4 Stephen Benjamin 2015-08-14 11:21:02 EDT
This is https://bugzilla.redhat.com/show_bug.cgi?id=1213000


PGError: ERROR:  could not create unique index "index_parameters_on_type_and_reference_id_and_name"
DETAIL:  Key (type, reference_id, name)=(GroupParameter, 2, kt_activation_keys) is duplicated.
: CREATE UNIQUE INDEX "index_parameters_on_type_and_reference_id_and_name" ON "parameters" ("type", "reference_id", "name")

*** This bug has been marked as a duplicate of bug 1213000 ***

Note You need to log in before you can comment on or make changes to this bug.