Bug 1253680 - Preupgrade-assistant doesn't inform what should be updated in kickstart
Preupgrade-assistant doesn't inform what should be updated in kickstart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Hracek
Tereza Cerna
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 08:47 EDT by Petr Hracek
Modified: 2015-11-19 20:41 EST (History)
8 users (show)

See Also:
Fixed In Version: preupgrade-assistant-2.1.0-6.el6
Doc Type: Bug Fix
Doc Text:
This bug fix contains a number of modifications to the preupgrade kickstart. Previously, the script did not receive warning to which components needed an upgrade before the kickstart could be implemented, and there was no warning telling the user to use the file as a reference and not to be used directly. These upgrades are implemented in this bug fix.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 20:41:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Hracek 2015-08-14 08:47:57 EDT
Description of problem:
Nowadays preupgrade-assistant generates a kickstart with the help of contents. 
Unfortunately on command line is mentioned only a path to kickstart file without information whether kickstart is prepared for RHEL 7 installation directly.

Report from `preupg` should be enhanced so that sections like users, repositories, packages and partitioning has to be properly updated before any RHEL-7 installation.
Also information that kickstart is only a draft and can not or should not be used directly for RHEL-7 installation before any modification.

Also hint for subscription manager should be mentioned in an output.

Kickstart log file should have a reference what to do after a RHEL-7 installation. This is not handled yet.

This bugzila should covered all these issues.

NOTE: Text has to be reviewed by documentation team. Admins and users will modify kickstart file and misunderstanding can cause a lot of problems in future.
Comment 11 errata-xmlrpc 2015-11-19 20:41:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2497.html

Note You need to log in before you can comment on or make changes to this bug.