Bug 1253701 - Pressing RETURN duplicates a received message window that has focus
Pressing RETURN duplicates a received message window that has focus
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
22
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 09:28 EDT by Martin Gregorie
Modified: 2015-08-17 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.17.91
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-17 10:05:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Gregorie 2015-08-14 09:28:56 EDT
Description of problem: 
Pressing RETURN when a window containing a received message has focus immediately duplicates that window.


Version-Release number of selected component (if applicable):
evolution 3.16.4

How reproducible:
Every time

Steps to Reproduce:
1. Open a previously received e-mail
2. While it has focus, press RETURN


Actual results:
The window is duplicated and given focus.

Expected results:
I expected the RETURN press to be ignored because the window can't be edited.

Additional info:
Each successive RETURN repeats the duplication and shifts focus to the new window. Seems to continue until you get bored with doing it.

This always happens and is unaffected by:
- Caret mode being on or off
- whether the cursor is on the text in the received message window window or not

A nice short cut would be for RETURN to open a Reply window and position the cursor inside it. However, this should be a configurable feature and should default to OFF.
Comment 1 Milan Crha 2015-08-17 10:05:30 EDT
Thanks for a bug report. I fixed it for the next evolution release with:
https://git.gnome.org/browse/evolution/commit/?id=cfa179f

Note You need to log in before you can comment on or make changes to this bug.