This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1253763 - gromacs: disable timing out test on ppc and s390
gromacs: disable timing out test on ppc and s390
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gromacs (Show other bugs)
22
ppc64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2015-08-14 11:54 EDT by Rafael Fonseca
Modified: 2016-06-23 01:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.1-1.fc24 gromacs-5.0.7-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:19:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disable mdrun test on ppc64 and s390 (2.06 KB, patch)
2015-08-14 11:54 EDT, Rafael Fonseca
no flags Details | Diff

  None (edit)
Description Rafael Fonseca 2015-08-14 11:54:38 EDT
Created attachment 1063074 [details]
Disable mdrun test on ppc64 and s390

Description of problem: mdrun test case times out on ppc64 and s390[x].


Version-Release number of selected component (if applicable): 5.0.6-4


How reproducible: koji-build gromacs on ppc64 and s390[x].


Actual results:

      Start 15: MdrunTests
15/15 Test #15: MdrunTests .......................***Timeout 1500.02 sec
[...]
WARNING: Using the slow plain C kernels. This should
not happen during routine usage on supported platforms.
[...]
93% tests passed, 1 tests failed out of 15
Label Time Summary:
GTest              =   3.38 sec
IntegrationTest    = 1500.85 sec
UnitTest           =   3.38 sec
Total Test time (real) = 1504.25 sec
The following tests FAILED:
	 15 - MdrunTests (Timeout)
CMakeFiles/run-ctest.dir/build.make:52: recipe for target 'CMakeFiles/run-ctest' failed
make[3]: Leaving directory '/builddir/build/BUILD/gromacs-5.0.6/openmpi'
CMakeFiles/Makefile2:963: recipe for target 'CMakeFiles/run-ctest.dir/all' failed
make[2]: Leaving directory '/builddir/build/BUILD/gromacs-5.0.6/openmpi'
CMakeFiles/Makefile2:940: recipe for target 'CMakeFiles/check.dir/rule' failed
make[1]: Leaving directory '/builddir/build/BUILD/gromacs-5.0.6/openmpi'
Makefile:547: recipe for target 'check' failed
RPM build errors:
Errors while running CTest
make[3]: *** [CMakeFiles/run-ctest] Error 8
make[2]: *** [CMakeFiles/run-ctest.dir/all] Error 2
make[1]: *** [CMakeFiles/check.dir/rule] Error 2
make: *** [check] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.rnrPs8 (%check)

Additional info:

this looks like a hardware problem. Looking for the warning found in the build log, I found this thread [1] explaining that devs assume one will run gromacs on GPU accelerated platforms, or at least with SIMD-capable CPU, and the P7 is still too slow. The attached patch disables such a test on the affected platforms.

[1] http://permalink.gmane.org/gmane.science.biology.gromacs.user/77673
Comment 1 Dominik 'Rathann' Mierzejewski 2015-08-17 09:15:11 EDT
Thanks for the report. I'm in the process of upgrading gromacs to 5.1 for f24 (and will probably backport to f23 once bugs are shaken out). It doesn't time out. There are a couple of other issues, though. One is an out-of-memory error when running the testsuite on s390 (but s390x runs fine). Another is a compilation error on ppc64/ppc64le (reported upstream). I'll push the updated version to git soon.
Comment 2 Dominik 'Rathann' Mierzejewski 2015-08-17 16:09:11 EDT
Fixed in rawhide. I tested on ppc.koji and s390.koji, but feel free to test yourself and reopen if there are still some issues.
Comment 3 Rafael Fonseca 2015-11-27 10:13:05 EST
It is indeed fixed for f>=23. Could you apply the fixes for f22 as well? Gromacs fails to build on f22/ppc64 [1].

[1] http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2938260

Thank you.
Comment 4 Dominik 'Rathann' Mierzejewski 2015-11-30 07:07:22 EST
Bumping down to F22.
Comment 5 Fedora Update System 2016-06-13 06:54:44 EDT
gromacs-5.0.7-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-39b236aba6
Comment 6 Fedora Update System 2016-06-13 18:27:30 EDT
gromacs-5.0.7-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-39b236aba6
Comment 7 Fedora Update System 2016-06-23 01:19:55 EDT
gromacs-5.0.7-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.