Bug 1253776 - [abrt] PackageKit: hy_repo_get_string(): packagekitd killed by SIGSEGV
[abrt] PackageKit: hy_repo_get_string(): packagekitd killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:61256160487a82538dd6d1dc322...
:
: 1271851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 12:30 EDT by Adam Williamson
Modified: 2016-05-10 14:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 14:00:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (22.63 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: cgroup (200 bytes, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: core_backtrace (12.64 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: dso_list (7.36 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: environ (120 bytes, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: maps (38.89 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: mountinfo (3.94 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: namespaces (85 bytes, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: open_fds (2.78 KB, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details
File: proc_pid_status (980 bytes, text/plain)
2015-08-14 12:30 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-08-14 12:30:25 EDT
Description of problem:
Not sure what's triggering this, but it seems to be preventing GNOME Software from working correctly on my F22 laptop.

Version-Release number of selected component:
PackageKit-1.0.6-6.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: hy_repo_get_string
executable:     /usr/libexec/packagekitd
global_pid:     1815
kernel:         4.1.3-201.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 hy_repo_get_string at /usr/src/debug/hawkey-0.5.7/py3/src/repo.c:200
 #1 load_yum_repo at /usr/src/debug/hawkey-0.5.7/py3/src/sack.c:552
 #2 hy_sack_load_repo at /usr/src/debug/hawkey-0.5.7/py3/src/sack.c:999
 #3 hy_sack_load_yum_repo at /usr/src/debug/hawkey-0.5.7/py3/src/sack.c:992
 #4 hif_sack_add_source at hif-sack.c:148
 #5 hif_sack_add_sources at hif-sack.c:201
 #6 hif_utils_add_remote at pk-backend-hif.c:490
 #7 hif_utils_create_sack_for_filters at pk-backend-hif.c:686
 #8 pk_backend_search_thread at pk-backend-hif.c:909
 #9 pk_backend_job_thread_setup at pk-backend-job.c:815
Comment 1 Adam Williamson 2015-08-14 12:30:29 EDT
Created attachment 1063090 [details]
File: backtrace
Comment 2 Adam Williamson 2015-08-14 12:30:30 EDT
Created attachment 1063091 [details]
File: cgroup
Comment 3 Adam Williamson 2015-08-14 12:30:31 EDT
Created attachment 1063092 [details]
File: core_backtrace
Comment 4 Adam Williamson 2015-08-14 12:30:32 EDT
Created attachment 1063093 [details]
File: dso_list
Comment 5 Adam Williamson 2015-08-14 12:30:33 EDT
Created attachment 1063094 [details]
File: environ
Comment 6 Adam Williamson 2015-08-14 12:30:34 EDT
Created attachment 1063095 [details]
File: limits
Comment 7 Adam Williamson 2015-08-14 12:30:36 EDT
Created attachment 1063096 [details]
File: maps
Comment 8 Adam Williamson 2015-08-14 12:30:37 EDT
Created attachment 1063097 [details]
File: mountinfo
Comment 9 Adam Williamson 2015-08-14 12:30:38 EDT
Created attachment 1063098 [details]
File: namespaces
Comment 10 Adam Williamson 2015-08-14 12:30:39 EDT
Created attachment 1063099 [details]
File: open_fds
Comment 11 Adam Williamson 2015-08-14 12:30:40 EDT
Created attachment 1063100 [details]
File: proc_pid_status
Comment 12 Adam Williamson 2015-08-14 13:06:30 EDT
The backtrace here looks a lot like https://bugzilla.redhat.com/show_bug.cgi?id=1135740 , but the libhif I have should be new enough to have that fixed...
Comment 13 Kalev Lember 2015-10-16 13:42:46 EDT
*** Bug 1271851 has been marked as a duplicate of this bug. ***
Comment 14 Kalev Lember 2015-10-16 13:48:33 EDT
This should be properly fixed upstream in https://github.com/rpm-software-management/libhif/commit/98e7f20ecc9d713239e6d68e4966a2195f62e642 , but we haven't managed to get that fix into Fedora yet.
Comment 15 Mike McCune 2016-03-28 19:26:37 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 16 Fedora Update System 2016-04-28 12:54:59 EDT
libhif-0.2.2-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ba5f1759c7
Comment 17 Fedora Update System 2016-04-28 18:54:24 EDT
libhif-0.2.2-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ba5f1759c7
Comment 18 Fedora Update System 2016-05-10 13:59:58 EDT
libhif-0.2.2-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.