Bug 1253787 - AttributeError: 'int' object has no attribute 'convertTo'
AttributeError: 'int' object has no attribute 'convertTo'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:78dde9805d3e11ae1e76d669515...
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-08-14 13:21 EDT by Adam Williamson
Modified: 2015-08-27 13:58 EDT (History)
9 users (show)

See Also:
Fixed In Version: 23.19.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 13:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (274.40 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: anaconda.log (34.55 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: dnf.log (1.44 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: environ (494 bytes, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: lsblk_output (1.26 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (1.18 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: program.log (31.47 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: storage.log (65.83 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: syslog (60.27 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: ifcfg.log (2.23 KB, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details
File: packaging.log (504 bytes, text/plain)
2015-08-14 13:21 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-08-14 13:21:06 EDT
Description of problem:
This is from an openQA LVM thin partitioning run on 2015-08-14 Rawhide
nightly. It just does 'create partitions for me' in custom partitioning,
to an empty disk, using LVM thinp. It crashes during the partitioning
stage of the installation process.

Version-Release number of selected component:
anaconda-23.19-1

The following was filed automatically by anaconda:
anaconda 23.19-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/lvm.py", line 1507, in populateKSData
    data.metadata_size = self.metaDataSize.convertTo(MiB)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 1835, in _updateCustomStorageKSData
    device.populateKSData(data)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 1795, in updateKSData
    self._updateCustomStorageKSData()
  File "/usr/lib/python3.4/site-packages/pyanaconda/install.py", line 180, in doInstall
    storage.updateKSData()  # this puts custom storage info into ksdata
  File "/usr/lib/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'int' object has no attribute 'convertTo'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-i386 quiet
dnf.rpm.log:    Aug 14 16:21:14 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc6.git0.2.fc24.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        Rawhide
Comment 1 Adam Williamson 2015-08-14 13:21:09 EDT
Created attachment 1063131 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2015-08-14 13:21:10 EDT
Created attachment 1063132 [details]
File: anaconda.log
Comment 3 Adam Williamson 2015-08-14 13:21:11 EDT
Created attachment 1063133 [details]
File: dnf.log
Comment 4 Adam Williamson 2015-08-14 13:21:12 EDT
Created attachment 1063134 [details]
File: environ
Comment 5 Adam Williamson 2015-08-14 13:21:14 EDT
Created attachment 1063135 [details]
File: lsblk_output
Comment 6 Adam Williamson 2015-08-14 13:21:15 EDT
Created attachment 1063136 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2015-08-14 13:21:16 EDT
Created attachment 1063137 [details]
File: os_info
Comment 8 Adam Williamson 2015-08-14 13:21:17 EDT
Created attachment 1063138 [details]
File: program.log
Comment 9 Adam Williamson 2015-08-14 13:21:19 EDT
Created attachment 1063139 [details]
File: storage.log
Comment 10 Adam Williamson 2015-08-14 13:21:20 EDT
Created attachment 1063140 [details]
File: syslog
Comment 11 Adam Williamson 2015-08-14 13:21:21 EDT
Created attachment 1063141 [details]
File: ifcfg.log
Comment 12 Adam Williamson 2015-08-14 13:21:22 EDT
Created attachment 1063142 [details]
File: packaging.log
Comment 13 Adam Williamson 2015-08-14 13:28:28 EDT
Proposing as an F23 beta blocker, as I'm pretty sure this code will be in F23 as well. Can't test it directly yet because the anaconda/blivet update for F23 is still in u-t, so F23 tests still crash earlier due to https://bugzilla.redhat.com/show_bug.cgi?id=1246901 . Criterion: "When using the custom partitioning flow, the installer must be able to:  ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions." - https://fedoraproject.org/wiki/Fedora_23_Beta_Release_Criteria#Custom_partitioning
Comment 14 Brian Lane 2015-08-17 17:25:43 EDT
I think commit 30c7c87ada93 is the fix for this, can you retry it with that applied?
Comment 15 Adam Williamson 2015-08-17 20:33:25 EDT
Yeah, that does look like it fixes it in a quick manual test.
Comment 16 Adam Williamson 2015-08-20 12:45:00 EDT
Discussed at 2015-08-20 blocker review meeting: http://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-08-20/f23-blocker-review.2015-08-20-16.05.log.txt . Accepted as a blocker per criterion cited in #c13.
Comment 17 Fedora Update System 2015-08-22 12:25:30 EDT
anaconda-23.19.1-1.fc23, python-blivet-1.12.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13831
Comment 18 Fedora Update System 2015-08-27 13:58:19 EDT
anaconda-23.19.1-1.fc23, python-blivet-1.12.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.