Bug 1253790 - Consume fix for "iscsi_session recovery_tmo revert back to default when a path becomes active"
Consume fix for "iscsi_session recovery_tmo revert back to default when a pat...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.0-rc3
: 4.17.9
Assigned To: Nir Soffer
Raz Tamir
storage
:
Depends On: 1253789
Blocks: 1272083
  Show dependency treegraph
 
Reported: 2015-08-14 13:36 EDT by Nir Soffer
Modified: 2016-03-10 10:12 EST (History)
14 users (show)

See Also:
Fixed In Version: vdsm-4.17.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1272083 (view as bug list)
Environment:
Last Closed: 2015-11-27 02:56:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
amureini: devel_ack+
amureini: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44851 master MERGED spec: Require newer kernel version on Fedora Never
oVirt gerrit 47207 ovirt-3.6 MERGED spec: Require newer kernel version on Fedora Never
oVirt gerrit 47473 ovirt-3.5 MERGED spec: Require newer kernel version on Fedora Never

  None (edit)
Description Nir Soffer 2015-08-14 13:36:09 EDT
Description of problem:

iSCSI default replacement_timeout is 120 seconds, resulting in too slow
iSCSI failover in multipath setup. In vdsm, this may lead to blocking of
multiple unrelated vdsm threads for many minutes, when lvm, multipath
ore scsi scan operation blocks.

This issue was resolved in multipath (bug 1099932), by configuring iscsi
session recovery_tmo sysfs attribute to multipath fast_io_fail_tmo
value, (5 seconds in vdsm configuration). However, this configuration
was reverted to the default 120 seconds after a device went down an up
again, or after restart of the iscsid daemon (bug 1139038).

This issue was fixed in kernel-3.10.0-295.el7. In this version, setting
session recovery_tmo using sysfs overrides the default value defined in
iscsid configuration file.

Vdsm need to require a kernel containing a fix for this issue on Fedora
versions including this fix.
Comment 1 Eyal Edri 2015-10-14 11:38:14 EDT
shouldn't this bug has 3.5.z? flag set if the target milestone is set to 3.5.6?
trying to understand how clone candidates are treated in the new classification
Comment 2 Allon Mureinik 2015-10-15 03:45:06 EDT
(In reply to Eyal Edri from comment #1)
> shouldn't this bug has 3.5.z? flag set if the target milestone is set to
> 3.5.6?
> trying to understand how clone candidates are treated in the new
> classification
Yeah, probably so.
This is waiting for qa-ack+ so we can clone it.
Gil - can you assist?
Comment 3 Raz Tamir 2015-11-22 03:46:42 EST
Verified on vdsm-4.17.10.1-0.el7ev.noarch with kernel 3.10.0-327.el7.x86_64
Comment 4 Sandro Bonazzola 2015-11-27 02:56:06 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.