Bug 125380 - ps/2 mouse not functional
ps/2 mouse not functional
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-05 12:46 EDT by Igor Mozetic
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:07:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Mozetic 2004-06-05 12:46:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040413 Debian/1.6-5

Description of problem:
I have a ps/2 3-button mouse. Works fine under RH9.
Under Fedora 2, it is detected, but doesn't move,
neither in console, not under X. Tried all configuration
variants I found with Google, and both kernels - no effect.

However, if I change the default kernel config from
CONFIG_MOUSE_PS2=y  to  CONFIG_MOUSE_PS2=m  and do
modprobe psmouse, then it works fine.

Version-Release number of selected component (if applicable):
2.6.5-1.358 2.6.6-1.422

How reproducible:
Always

Steps to Reproduce:
1.boot into default kernel 2.6.5 or 2.6.6
2.try to move the mouse
3.
    

Additional info:
Comment 1 Target 2004-08-22 23:40:54 EDT
I have the same problem. The mouse was detected but did not work
during install or afterwards. gpm loads without incident, but there is
no cursor. Likewise, X starts but the mouse cursor just sits in the
middle of the screen. Running system-config-mouse doesn't help.

Mouse is a 3-button ps/2 Logitech Mouseman.

Using the ps2 mouse kernel module instead of built-in functions as a
workaround, but it'd be nice to have a proper fix.
Comment 2 root 2004-09-12 01:21:36 EDT
Same problem here, I have an older SGI PS/2 3-button mouse.  Worked
fine in RH 8.0, upgraded to FC2 and I get a pointer but can't move it
or click.  

Where do you set CONFIG_MOUSE_PS2?  Is that in one of the config files
or do you pass that to the kernel as a boot argument?  
Comment 3 Vasile Gaburici 2004-11-17 15:57:36 EST
Same problem here with a Logitech OEM (Dell) 3-button mouse PS/2
mouse: it's frozen. I haven't tried to recompile the kernel. Just
switched to a USB mouse.

Here is /proc/bus/input/devices:

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
H: Handlers=kbd event0
B: EV=120013
B: KEY=4 2000000 3802078 f840d001 f2ffffdf ffefffff ffffffff fffffffe
B: MSC=10
B: LED=7

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
H: Handlers=mouse0 event1
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

I: Bus=0003 Vendor=0f03 Product=0001 Version=0001
N: Name="Ver 1.0 USB To RS232 Interface (V1.0) BaudRate 2400bps"
P: Phys=usb-0000:00:1d.1-2/input0
H: Handlers=event2
B: EV=20003
B: KEY=ffff ffffffff ffff0000 0 0 0 0 0 0 0 0 0
B: LED=ffff

I: Bus=0003 Vendor=046d Product=c016 Version=0340
N: Name="Logitech Optical USB Mouse"
P: Phys=usb-0000:00:1d.2-2/input0
H: Handlers=mouse1 event3
B: EV=f
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
B: ABS=100 0
Comment 4 Vasile Gaburici 2004-11-17 15:58:35 EST
Update: my report is against FC3 not 2.
Comment 5 Dave Jones 2005-04-16 01:07:12 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.