Bug 125383 - Missing sasl2 support in sendmail-8.12.11
Missing sasl2 support in sendmail-8.12.11
Status: CLOSED DUPLICATE of bug 124086
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-06-05 15:12 EDT by Robert Scheck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-06-05 15:12:17 EDT
Description of problem:
After an upgrade from sendmail-8.12.10-1 to sendmail-8.12.11-3.3 
the sasl2 support isn't any longer available - so why?! In my eyes, 
something simply went wrong, but please look yourself:

--- snipp ---
# rpm -qpl sendmail-8.12.10-1.i386.rpm | grep sasl
# rpm -qpl sendmail-8.12.11-3.3.i386.rpm | grep sasl
--- snapp ---

Version-Release number of selected component (if applicable):

How reproducible & Steps to Reproduce:
Everytime; upgrade from sendmail-8.12.10-1 to sendmail-8.12.11-3.3 
and find the missing sasl2 support...

Actual results:
Well, in the spec file of sendmail-8.12.11-3.3 I found:

--- snipp ---
%define       with_sasl2    no
--- snapp ---

Expected results:
To support sasl2 again, as it was case in 8.12.10-1, do

--- snipp ---
%define       with_sasl2    yes
--- snapp ---

and rebuild it - which solved it for me personally, but I still can't 
really do that at a supported RHEL3 at our customers...
Comment 1 Nalin Dahyabhai 2004-06-07 12:14:51 EDT
The reason for the change was that sendmail also used LDAP.  In RHEL3,
libldap uses sasl version 1, so sendmail ended up with both versions
of the library loaded at run-time (you can verify this by running
"ldd" against the sendmail binary).

Because both version 1 and 2 of the sasl library provide symbols with
the same names but which are binary-incompatible, there's no guarantee
that that combination could ever work reliably (i.e., without causing
sendmail to crash, which would actually be the most likely outcome),
so the change had to be made.
Comment 2 Robert Scheck 2004-06-07 17:00:43 EDT
Nice...but I still hope, that this isn't the final answer for my issue.

Because I really can't tell that reason to my colleagues and our 
customers, because they want to use saslauthd/sasl2. And offering them 
my personal (for me) working hack, isn't a supported solution for RHEL3
productive systems...
Comment 3 Thomas Woerner 2004-06-08 05:19:01 EDT
I am sorry, but this is the final answer.

Please use sasl1 instead.
Comment 4 Thomas Woerner 2004-06-08 05:19:31 EDT

*** This bug has been marked as a duplicate of 124086 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:03:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.