Bug 1253831 - glusterd: clean dead initializations
glusterd: clean dead initializations
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Prasanna Kumar Kalever
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-14 16:07 EDT by Prasanna Kumar Kalever
Modified: 2016-06-16 09:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanna Kumar Kalever 2015-08-14 16:07:36 EDT
Description of problem:
clean unused variable initialization as well as their declarations which are no where used in the code

Version-Release number of selected component (if applicable):
mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-14 16:08:46 EDT
REVIEW: http://review.gluster.org/11929 (glusterd: clean dead initializations) posted (#1) for review on master by Prasanna Kumar Kalever
Comment 2 Vijay Bellur 2016-03-17 11:13:15 EDT
REVIEW: http://review.gluster.org/11929 (glusterd: clean dead initializations) posted (#3) for review on master by Prasanna Kumar Kalever (prasanna.kalever@redhat.com)
Comment 3 Vijay Bellur 2016-03-17 12:43:45 EDT
REVIEW: http://review.gluster.org/11929 (glusterd: clean dead initializations) posted (#4) for review on master by Prasanna Kumar Kalever (prasanna.kalever@redhat.com)
Comment 4 Vijay Bellur 2016-04-04 17:41:13 EDT
COMMIT: http://review.gluster.org/11929 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 3394c555171775c6f74c2c556265b044a70a2fa9
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Sat Aug 15 01:29:31 2015 +0530

    glusterd: clean dead initializations
    
    This patch cleans unused variable initialization as well as their declarations
    which are no where used in the code
    
    Change-Id: I784165fc6e91297758079699dd9583d5203b7793
    BUG: 1253831
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/11929
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:31:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.